Bug 735747 - Getting [object object] on UI while adding 'organization' specific permissions to a role
Summary: Getting [object object] on UI while adding 'organization' specific permission...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-09-05 09:31 UTC by Sachin Ghai
Modified: 2013-08-16 18:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:55:19 UTC


Attachments (Terms of Use)
depicts [object object] in UI and no user notification generated for this (55.48 KB, image/png)
2011-09-05 09:32 UTC, Sachin Ghai
no flags Details
Getting Internal Server Error while deleting that role, this makes the stale entries of roles (19.46 KB, image/png)
2011-09-05 09:33 UTC, Sachin Ghai
no flags Details

Description Sachin Ghai 2011-09-05 09:31:02 UTC
Description of problem:
I tried to create a role and start adding 'organization specific permissions to that role. However after adding the appropriate permissions to that role, got a pop-up on UI saying [object] [object]. See the first attachment.

Version-Release number of selected component (if applicable):
katello-0.1.75-1.git.41.2e9f377.fc15.noarch


How reproducible:
always

Steps to Reproduce:
1. Go to administration ==> Role ==> new role
2. Define the name of role say  : 'testrole1' and click save
3.  Now select the testrole1  from left pane as below:
testrole1 ==> Permissions ==> Global Permissions
4. Click '+Add permission' and define permission name say 'org'
5. Click next and select 'organization' from 'Permission for'and click next
6. Select following verbs:
   - Access system
   - Access organization
   - Create organization
   - Register Systems
7. click 'Done'

Actual results:
Pop up appears on UI  with [object object ] and when you click on testrole1 on left pane:

There was an error retrieving that row: Internal Server Error 

See the second attachment for ISE. This makes the stale entries on UI.

Expected results:
Should n't be any error while adding organization specific permissions to a role

Additional info:

This happens only when you choose following verbs while defining permissions for 'Organization' tab

   - Access system
   - Access organization
   - Create organization
   - Register Systems

if we don't select the 'create organization' verb then it successfully adds the permissions to defined role without any error.

Comment 1 Sachin Ghai 2011-09-05 09:32:40 UTC
Created attachment 521468 [details]
depicts [object object] in UI and no user notification generated for this

Comment 2 Sachin Ghai 2011-09-05 09:33:53 UTC
Created attachment 521469 [details]
Getting Internal Server Error while deleting that role, this makes the stale entries of roles

Comment 3 Justin Sherrill 2011-09-09 13:35:45 UTC
Should be fixed in master:

e0285476a1c9f68bf95699ae30f001580aeade61

Comment 4 Jeff Weiss 2011-09-26 16:38:42 UTC
Verified, katello-0.1.84-1.git.26.51fa1e1.fc14.noarch

Comment 7 Mike McCune 2013-08-16 18:15:43 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.