Bug 735804 - Not able to install Katello on RHEL
Summary: Not able to install Katello on RHEL
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Packaging
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: Lukas Zapletal
QA Contact: Garik Khachikyan
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-09-05 13:37 UTC by Lukas Zapletal
Modified: 2015-01-04 21:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:55:23 UTC


Attachments (Terms of Use)

Description Lukas Zapletal 2011-09-05 13:37:57 UTC
It is probably the same on Fedora

# yum -y install katello
Loaded plugins: product-id, rhnplugin, subscription-manager
Updating Red Hat repositories.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package katello.noarch 0:0.1.75-1.git.41.2e9f377.el6 will be installed
--> Processing Dependency: rubygem(daemons) >= 1.1.4 for package: katello-0.1.75-1.git.41.2e9f377.el6.noarch
--> Processing Dependency: rubygem(scoped_search) >= 2.3.1 for package: katello-0.1.75-1.git.41.2e9f377.el6.noarch
--> Processing Dependency: rubygem(rails) >= 3.0.5 for package: katello-0.1.75-1.git.41.2e9f377.el6.noarch
[...]
---> Package katello.noarch 0:0.1.75-1.git.41.2e9f377.el6 will be installed
--> Processing Dependency: rubygem(sqlite3) for package: katello-0.1.75-1.git.41.2e9f377.el6.noarch
--> Processing Dependency: rubygem(multimap) for package: katello-0.1.75-1.git.41.2e9f377.el6.noarch
--> Processing Dependency: rubygem(pg) for package: katello-0.1.75-1.git.41.2e9f377.el6.noarch
---> Package rubygem-mime-types.noarch 0:1.16-4.el6 will be installed
--> Processing Dependency: rubygem(rcov) >= 0.8 for package: rubygem-mime-types-1.16-4.el6.noarch
---> Package rubygem-ronn.noarch 0:0.7.3-6.el6 will be installed
--> Processing Dependency: rubygem(hpricot) >= 0.8.2 for package: rubygem-ronn-0.7.3-6.el6.noarch
--> Processing Dependency: rubygem(rdiscount) >= 1.5.8 for package: rubygem-ronn-0.7.3-6.el6.noarch
---> Package rubygem-tilt.noarch 0:1.2.2-2.el6 will be installed
--> Finished Dependency Resolution
Error: Package: rubygem-mime-types-1.16-4.el6.noarch (epel-katello)
           Requires: rubygem(rcov) >= 0.8
Error: Package: rubygem-ronn-0.7.3-6.el6.noarch (epel-katello)
           Requires: rubygem(rdiscount) >= 1.5.8
Error: Package: rubygem-ronn-0.7.3-6.el6.noarch (epel-katello)
           Requires: rubygem(hpricot) >= 0.8.2
Error: Package: katello-0.1.75-1.git.41.2e9f377.el6.noarch (epel-katello)
           Requires: rubygem(pg)
Error: Package: katello-0.1.75-1.git.41.2e9f377.el6.noarch (epel-katello)
           Requires: rubygem(multimap)
Error: Package: katello-0.1.75-1.git.41.2e9f377.el6.noarch (epel-katello)
           Requires: rubygem(sqlite3)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 1 Lukas Zapletal 2011-09-05 13:41:43 UTC
Tagged and retriggered RPM build via bot to see if it helps.

Comment 2 Lukas Zapletal 2011-09-05 14:13:13 UTC
Our repo was corrupt. Regenerated. Solved the issue.

Comment 3 Lukas Zapletal 2011-09-05 14:26:39 UTC
Jan reports it did not help him. QA's installer works. Will give it another shot.

@Garik - why your installer works and Jan's box is failing to install this? ^

Comment 4 Garik Khachikyan 2011-09-05 14:29:54 UTC
@Lukas: there was an issue (the installer package was renamed to python_katello - was python-katello) ... 

So the whole stuff was not proceed there.

Now when the issue is fixed (also the EPEL repo installation needed for RHEL6 there) - it should work. 

The issue could get "fixed" for now (and /me will come with reworked python_katello soon that returns proper exit code).

Comment 5 Lukas Zapletal 2011-09-05 19:02:54 UTC
@Garik - I think you dont understand me - your install script is working (I can confirm that), but adelton is using instructions from our wiki page. And it does not work.

Comment 6 Lukas Zapletal 2011-09-06 07:01:20 UTC
Jan reported it works, cool. We will need to improve our Installation page and how we do handle with it.

Comment 7 Garik Khachikyan 2011-09-14 11:26:44 UTC
Our install wiki now states about having some additional packages for RHEL6 case.

https://fedorahosted.org/katello/wiki/Install#General

Considering this ^ - RHEL6 installation (already using the puppet-way) goes fine.


Note You need to log in before you can comment on or make changes to this bug.