Bug 735814 - Cannot use discrete graphics card on hybrid graphics laptop
Summary: Cannot use discrete graphics card on hybrid graphics laptop
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-05 14:31 UTC by Nathan Thomas
Modified: 2018-04-11 17:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-07 09:07:22 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 40678 None None None Never

Description Nathan Thomas 2011-09-05 14:31:37 UTC
Description of problem:

I have one of those clever 'hybrid graphics' laptops that are designed to use an integrated graphics card for everyday stuff, and switch automatically to a more powerful discrete card for more graphics-intensive uses. However, under Fedora the discrete graphics card is never used - I appear to be stuck with the integrated card at all times. Though I always suspected it, I didn't know how to check which card was being used until I ran a few tests from the Phoronix Test Suite - the test results indicated that only the integrated card had been used. The tests simulate the playing of graphics-intensive games, a use case which should in theory activate my discrete card.

I tried using David Airlie's 'switcheroo' fix, as described here: http://linux-hybrid-graphics.blogspot.com/2010/07/using-acpicall-module-to-switch-onoff.html

However, the fix didn't work for me. I noticed that most of the users who were reporting success with switcheroo were using hybrid setups with an Intel integrated card and an NVIDIA discrete one, whereas mine are both AMD/ATI (Radeon 3200HD and 3450HD, respectively).

While I'm not a heavy gamer, this problem leaves me unable to do the things a discrete graphics card is supposed to allow you to do, such as edit high-quality video, or even make a Skype video call without glitches.


Version-Release number of selected component (if applicable):
Fedora 15 Desktop x86_64
kernel-2.6.40-3.fc15 (x86_64)
xorg-x11-server-Xorg-1.10.3-1.fc15 (x86_64)
xorg-x11-drv-ati-6.14.1-2.20110525gitfe5c42f51.fc15 (x86_64)
Phoronix Test Suite v.3.2.0
The graphics section of System Settings > System Info says "Driver: Gallium 0.4 on AMD RV620"

smolt profile: http://www.smolts.org/client/show/pub_3485f516-bbd4-457e-8108-a1bfc65ff712


How reproducible:
Not quite sure how to do this! I suppose one way would be to run the Phoronix Test Suite.

Steps to Reproduce:
1. Install Phoronix Test Suite on a machine with a hybrid AMD/AMD graphics setup
2. Run a graphics-intensive test, such as the OpenArena test
3. Check the results to see what graphics card has been used
  
Actual results:
The test reports that the integrated graphics card has been used.

Expected results:
When the test is started, the laptop should switch to using the discrete graphics card.

Additional info:
Actually, automatic switching would be a luxury - I'd settle for a way to manually toggle between the two cards. Or even some way to permanently switch to the discrete card - the laptop's battery life is already abysmal and I never use it away from my desk anyway!

Comment 1 Matěj Cepl 2011-09-07 09:07:22 UTC
We filed this bug in the upstream database (https://bugs.freedesktop.org/show_bug.cgi?id=40678) and believe that it is more appropriate to let it be resolved upstream.

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

We would strongly encourage you to subscribe to the upstream bug as well (by logging in and adding yourself to the Cc list), so that you can provide whatever information required for the successful resolving of this issue.

Thank you for helping to make free software better.

Comment 2 Nathan Thomas 2011-09-07 09:54:51 UTC
Thanks Matĕj, I've added myself to the cc list upstream.


Note You need to log in before you can comment on or make changes to this bug.