Bug 735859 - rv515_fini / rv370_pcie_wreg - the code is fine but needs lockdep annotation
Summary: rv515_fini / rv370_pcie_wreg - the code is fine but needs lockdep annotation
Keywords:
Status: CLOSED DUPLICATE of bug 735860
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-05 18:23 UTC by Mads Kiilerich
Modified: 2018-04-11 14:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-07 08:18:29 UTC


Attachments (Terms of Use)
smolt and dmesg (81.92 KB, text/plain)
2011-09-05 18:23 UTC, Mads Kiilerich
no flags Details

Description Mads Kiilerich 2011-09-05 18:23:02 UTC
Created attachment 521529 [details]
smolt and dmesg

kernel-PAE-3.0.1-3.fc16.i686
xorg-x11-drv-ati-6.14.2-2.20110727git8c9266ed2.fc16.i686

[    4.160503] [drm] Initialized drm 1.1.0 20060810
[    4.230762] [drm] radeon defaulting to kernel modesetting.
[    4.233711] [drm] radeon kernel modesetting enabled.
[    4.236693] checking generic (80010000 6f0000) vs hw (80000000 10000000)
[    4.236696] fb: conflicting fb hw usage radeondrmfb vs EFI VGA - removing generic driver
[    4.248080] setfont used greatest stack depth: 6184 bytes left
[    4.251359] Console: switching to colour dummy device 80x25
[    4.255330] radeon 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[    4.255344] radeon 0000:01:00.0: setting latency timer to 64
[    4.260919] [drm] initializing kernel modesetting (RV530 0x1002:0x71C5).
[    4.261021] [drm] register mmio base: 0x98300000
[    4.261027] [drm] register mmio size: 65536
[    4.261414] radeon 0000:01:00.0: Invalid ROM contents
[    4.261555] radeon 0000:01:00.0: Invalid ROM contents
[    4.261607] [drm:radeon_get_bios] *ERROR* Unable to locate a BIOS ROM
[    4.261614] radeon 0000:01:00.0: Fatal error during GPU init
[    4.261621] [drm] radeon: finishing device.
[    4.261626] [TTM] Memory type 2 has not been initialized.
[    4.261684] [drm] radeon: cp finalized
[    4.261704] INFO: trying to register non-static key.
[    4.261709] the code is fine but needs lockdep annotation.
[    4.261714] turning off the locking correctness validator.
[    4.261722] Pid: 114, comm: modprobe Not tainted 3.0.1-3.fc16.i686.PAE #1
[    4.261730] Call Trace:
[    4.261740]  [<c084512a>] ? printk+0x2d/0x2f
[    4.261749]  [<c0470eb7>] register_lock_class+0xd5/0x23a
[    4.261758]  [<c045b317>] ? insert_wq_barrier+0xaf/0xaf
[    4.261765]  [<c0472a78>] __lock_acquire+0xa6/0xb57
[    4.261772]  [<c040dfd0>] ? native_sched_clock+0x41/0x94
[    4.261780]  [<c045b317>] ? insert_wq_barrier+0xaf/0xaf
[    4.261786]  [<c047393d>] lock_acquire+0xad/0xe4
[    4.261793]  [<c045b317>] ? insert_wq_barrier+0xaf/0xaf
[    4.261800]  [<c045b379>] wait_on_work+0x62/0x117
[    4.261806]  [<c045b317>] ? insert_wq_barrier+0xaf/0xaf
[    4.261813]  [<c0473bc0>] ? mark_held_locks+0x3b/0x57
[    4.261822]  [<c084e079>] ? _raw_spin_unlock_irq+0x27/0x2f
[    4.261829]  [<c0473cda>] ? trace_hardirqs_on_caller+0xfe/0x11f
[    4.261837]  [<c0473d06>] ? trace_hardirqs_on+0xb/0xd
[    4.261844]  [<c084e07e>] ? _raw_spin_unlock_irq+0x2c/0x2f
[    4.261851]  [<c045b6d1>] ? start_flush_work+0x121/0x12b
[    4.261858]  [<c045b70a>] flush_work_sync+0x2f/0x65
[    4.261864]  [<c0473bc0>] ? mark_held_locks+0x3b/0x57
[    4.261871]  [<c0470020>] ? usage_match+0x15/0x18
[    4.261878]  [<c084cd1f>] ? __mutex_unlock_slowpath+0xf5/0xfa
[    4.261927]  [<f846d50a>] ? rv370_pcie_wreg+0x2e/0x32 [radeon]
[    4.261973]  [<f846e925>] ? rv370_pcie_gart_disable+0x65/0xe1 [radeon]
[    4.262009]  [<f8465ae2>] radeon_irq_kms_fini+0x47/0x4a [radeon]
[    4.262009]  [<f847496b>] rv515_fini+0x3a/0x67 [radeon]
[    4.262009]  [<f8444e66>] radeon_device_fini+0x31/0x81 [radeon]
[    4.262009]  [<f8445ec1>] radeon_driver_unload_kms+0x24/0x3b [radeon]
[    4.262009]  [<f8446002>] radeon_driver_load_kms+0x12a/0x136 [radeon]
[    4.262009]  [<f7c3d9da>] drm_get_pci_dev+0x148/0x23a [drm]
[    4.262009]  [<f8493df0>] ? radeon_pci_probe+0xb0/0xc7 [radeon]
[    4.262009]  [<f8493dff>] radeon_pci_probe+0xbf/0xc7 [radeon]
[    4.262009]  [<c060604c>] pci_device_probe+0x62/0xab
[    4.262009]  [<c06a86c2>] driver_probe_device+0x129/0x208
[    4.262009]  [<c084cc24>] ? mutex_lock_nested+0x43/0x49
[    4.262009]  [<c06a87f0>] __driver_attach+0x4f/0x6b
[    4.262009]  [<c06a78b3>] bus_for_each_dev+0x42/0x6b
[    4.262009]  [<c06a82f5>] driver_attach+0x1f/0x23
[    4.262009]  [<c06a87a1>] ? driver_probe_device+0x208/0x208
[    4.262009]  [<c06a7f7b>] bus_add_driver+0xcd/0x214
[    4.262009]  [<c06a8c36>] driver_register+0x84/0xe3
[    4.262009]  [<c05f30ab>] ? __raw_spin_lock_init+0x2d/0x4e
[    4.262009]  [<c06067c4>] __pci_register_driver+0x4f/0xab
[    4.262009]  [<f7c5e000>] ? 0xf7c5dfff
[    4.262009]  [<f7c5e000>] ? 0xf7c5dfff
[    4.262009]  [<f7c3db49>] drm_pci_init+0x7d/0xd9 [drm]
[    4.262009]  [<f7c5e000>] ? 0xf7c5dfff
[    4.262009]  [<f7c5e0d9>] radeon_init+0xd9/0x1000 [radeon]
[    4.262009]  [<c04030a2>] do_one_initcall+0x8c/0x146
[    4.262009]  [<c04296db>] ? set_memory_nx+0x38/0x3a
[    4.262009]  [<f7c5e000>] ? 0xf7c5dfff
[    4.262009]  [<f7c5e000>] ? 0xf7c5dfff
[    4.262009]  [<c047ced1>] sys_init_module+0x14b9/0x16dd
[    4.262009]  [<c085421f>] sysenter_do_call+0x12/0x38
[    4.262511] vga_switcheroo: disabled
[    4.262993] radeon 0000:01:00.0: PCI INT A disabled
[    4.263050] radeon: probe of 0000:01:00.0 failed with error -22

Comment 1 Matěj Cepl 2011-09-07 08:18:29 UTC

*** This bug has been marked as a duplicate of bug 735860 ***


Note You need to log in before you can comment on or make changes to this bug.