Bug 735867 - extraneous error message: "rmmod[885]: ERROR: Module scsi_wait_scan does not exist in /proc/modules"
Summary: extraneous error message: "rmmod[885]: ERROR: Module scsi_wait_scan does not ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 752344 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-05 20:13 UTC by Mads Kiilerich
Modified: 2014-03-17 03:28 UTC (History)
7 users (show)

Fixed In Version: initscripts-9.34.2-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-15 02:23:19 UTC


Attachments (Terms of Use)
Dmesg from Virtualbox (53.68 KB, application/octet-stream)
2011-11-11 11:42 UTC, Vasiliy Glazov
no flags Details
Dmesg from hardware (93.90 KB, application/octet-stream)
2011-11-11 11:44 UTC, Vasiliy Glazov
no flags Details

Description Mads Kiilerich 2011-09-05 20:13:50 UTC
In the situation also reported on bug 735866 an rmmod error pops up:

[   12.974328] udevd[780]: failed to execute '/sbin/initqueue' '/sbin/initqueue --settled --onetime --unique /sbin/dmsquash-live-root /dev/sdc': No such file or directory
[  130.927626] udevadm[494]: udevadm settle - timeout of 120 seconds reached, the event queue contains:
[  130.927758] udevadm[494]: /sys/devices/virtual/tty/tty4 (2124)
[  130.932233] systemd[1]: udev-settle.service: main process exited, code=exited, status=1
[  130.965870] systemd[1]: Unit udev-settle.service entered failed state.
[  131.030223] rmmod[885]: ERROR: Module scsi_wait_scan does not exist in /proc/modules

I guess that is because systemd now logs all output, and the "try to rmmod and see what happens" approach used in /lib/systemd/system/fedora-wait-storage.service shows up as being less elegant.

initscripts-9.32-1.fc16.x86_64
udev-173-3.fc16.x86_64
dracut-013-8.fc16.noarch
systemd-35-1.fc16.x86_64

Comment 1 Vasiliy Glazov 2011-11-11 07:49:35 UTC
I confirm this bug in F16.

Comment 2 Mads Kiilerich 2011-11-11 11:00:46 UTC
vascom2: do you also see bug 735866?

Comment 3 Vasiliy Glazov 2011-11-11 11:07:53 UTC
No. I see only this string:
rmmod[885]: ERROR: Module scsi_wait_scan does not exist in /proc/modules

Comment 4 Mads Kiilerich 2011-11-11 11:26:47 UTC
vascom2: it would probably be helpful if you could attach the whole dmesg and report the potentially-involved package versions.

Comment 5 Vasiliy Glazov 2011-11-11 11:42:47 UTC
Created attachment 533034 [details]
Dmesg from Virtualbox

Comment 6 Vasiliy Glazov 2011-11-11 11:44:33 UTC
Created attachment 533035 [details]
Dmesg from hardware

Comment 7 Vasiliy Glazov 2011-11-11 11:45:23 UTC
I'am see this string in all Fedora 16 installations.

Comment 8 Bill Nottingham 2011-11-11 16:21:32 UTC
Right, it will likely come up, but it's a harmless error.

Comment 9 Bill Nottingham 2011-11-11 17:21:10 UTC
Fixed with: http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=c0e2c32eebea3c99807ca5f0505dcb020250a2a6

This will go out in some future Fedora 16 update.

Comment 10 Bill Nottingham 2012-03-06 21:50:24 UTC
*** Bug 752344 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2012-03-09 16:56:57 UTC
initscripts-9.35-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/initscripts-9.35-1.fc17

Comment 12 Fedora Update System 2012-03-09 17:57:54 UTC
Package initscripts-9.35-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing initscripts-9.35-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3459/initscripts-9.35-1.fc17
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2012-03-09 18:25:51 UTC
initscripts-9.34.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/initscripts-9.34.1-1.fc16

Comment 14 Fedora Update System 2012-03-12 18:22:42 UTC
initscripts-9.34.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/initscripts-9.34.2-1.fc16

Comment 15 Fedora Update System 2012-03-15 02:23:19 UTC
initscripts-9.34.2-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Vasiliy Glazov 2012-03-15 16:26:53 UTC
Yes, it solve problem.


Note You need to log in before you can comment on or make changes to this bug.