Bug 735879 - ibus update fails if /bin/sh is not bash
ibus update fails if /bin/sh is not bash
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-05 20:24 EDT by Karl
Modified: 2011-09-30 14:34 EDT (History)
3 users (show)

See Also:
Fixed In Version: ibus-1.3.99.20110817-4.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-15 21:55:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karl 2011-09-05 20:24:06 EDT
Description of problem:
ibus update fails if /bin/sh is not bash-compatible (but is still sh-compatible).

Version-Release number of selected component (if applicable):
ibus-1.3.99.20110419-13.fc15.x86_64
  (may still exist in ibus-1.3.99.20110419-18.fc15.x86_64)

How reproducible:
Always

Steps to Reproduce:
1. rpm -q dash || yum -y install dash
2. ln -sf /bin/dash /bin/sh
3. yum update ibus
  
Actual results:
  ibus reports the following error:
"Error in PREIN scriptlet in rpm package ibus-1.3.99.20110419-18.fc15.x86_64
/var/tmp/rpm-tmp.KHyekE: 4: Syntax error: Bad fd number
error: %pre(ibus-1.3.99.20110419-18.fc15.x86_64) scriptlet failed, exit status 2
ibus-1.3.99.20110419-13.fc15.x86_64 was supposed to be removed but is not!"

Expected results:
Update proceeds normally.

Additional info:
Error goes away if /bin/sh is a symbolic link to /bin/bash.
Comment 1 fujiwara 2011-09-05 23:16:16 EDT
OK, I will include the fix when I will release the new version.

http://pkgs.fedoraproject.org/gitweb/?p=ibus.git;a=commitdiff;h=de2d671b4b7deb6cdfcdc9c4b05dde8788a4aa31;hp=3bcb3ac4870d88b31027e8e1727f111a9421a3d0

Probably I don't think this fix is needed asap since you know the workaround.
Comment 2 Fedora Update System 2011-09-08 03:26:46 EDT
ibus-1.3.99.20110817-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-1.3.99.20110817-4.fc16
Comment 3 Fedora Update System 2011-09-08 03:26:54 EDT
ibus-1.3.99.20110817-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-1.3.99.20110817-4.fc15
Comment 4 Fedora Update System 2011-09-08 16:48:43 EDT
Package ibus-1.3.99.20110817-4.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.3.99.20110817-4.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/ibus-1.3.99.20110817-4.fc16
then log in and leave karma (feedback).
Comment 5 Karl 2011-09-10 17:31:14 EDT
The build in updates-testing for Fedora 15 seems to work just fine.
Comment 6 Fedora Update System 2011-09-15 21:55:38 EDT
ibus-1.3.99.20110817-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2011-09-30 14:34:48 EDT
ibus-1.3.99.20110817-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.