Bug 7359 - mail2fax parsing error
Summary: mail2fax parsing error
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-26 22:34 UTC by Jesus Navarro
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:47:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jesus Navarro 1999-11-26 22:34:25 UTC
Mail to fax gateway activated thro linuxconf.
When a valid e-mail is recieved thro sendmail, mail2fax program is
invocated.  It tries to split the message from header to send it to fax.
Part of this is made be the mail2fax program.
There is, within mail2fax, a call to the mail2fax_parsename function
(within mailhead.cc) which expects, as is commented in the source code the
e-mail address with one of these formats:

username <e-mail>
email <username>
or
email

Still, at least Windows' version of both Internet Explorer (5.0 was tested)
and Nestcape Communicator (version 4.04 was tested) send this with the
format:
"username" <email>
(note the double quotes at "username"), so mail2fax, in this case, returns
"username" instead of username.  Being double quotes a forbidden char
within mail2fax, the program througs away the fax with the

Fax with invalid characters: rejected

message.

Comment 1 Jesus Navarro 1999-12-01 18:02:59 UTC
Well, a bit more about *when* mail clients will send the From: field between
doble quotes.  Outlook seems to be very "stubborn", it seems that always will
send it so.  Netscape, on the other hand seems to only do so when "nasty"
characters appear.
For instance, being my name Jeszs M. NAVARRO, Netscape would send:
"Jeszs M. NAVARRO" <user@domain>
"Jesus M. NAVARRO" <user@domain>
but...
Jesus M NAVARRO <user@domain>
That is, if 8bit chars found, then it uses double quotes, so it does if a
dot "." appears, but it doesn't worry about blanks.  Outlook would send
even "NAVARRO" between double quotes.
I don't know if it's "legal" send the From: field (the one of the header,
nothing about the envelope's From field) quoted or not, but it really seems to
me the solution goes through modifying mail2fax_parsename method to take care
about the "Name" <user@domain> structure...

Comment 2 Jesus Navarro 1999-12-17 18:29:59 UTC
Well... Jacques Gelinas has been working: he has provided me with a new version
of mail2fax which workarounds the problem...

Comment 3 Brent Fox 2002-06-05 16:12:14 UTC
Closing because we don't ship linuxconf anymore

Comment 4 Red Hat Bugzilla 2006-02-21 18:47:34 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.