Bug 735935 - autofs mounts show IP rather than hostname after upgrade to RHEL 5.7
Summary: autofs mounts show IP rather than hostname after upgrade to RHEL 5.7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs
Version: 5.7
Hardware: x86_64
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Ian Kent
QA Contact: yanfu,wang
URL:
Whiteboard:
Depends On: 725536
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-06 07:57 UTC by RHEL Product and Program Management
Modified: 2018-12-02 19:19 UTC (History)
12 users (show)

Fixed In Version: autofs-5.0.1-0.rc2.156.el5_7.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-20 07:14:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1318 normal SHIPPED_LIVE autofs bug fix update 2011-09-20 07:14:35 UTC
Red Hat Knowledge Base (Legacy) 60620 None None None Never

Description RHEL Product and Program Management 2011-09-06 07:57:17 UTC
This bug has been copied from bug #725536 and has been proposed
to be backported to 5.7 z-stream (EUS).

Comment 6 yanfu,wang 2011-09-14 02:56:54 UTC
reproduced on RHEL5.7:
# rpm -qa|grep autofs
autofs-5.0.1-0.rc2.156.el5
# uname -a
Linux intel-s3e3144-01.rhts.eng.nay.redhat.com 2.6.18-274.el5PAE #1 SMP Fri Jul 8 17:59:09 EDT 2011 i686 i686 i386 GNU/Linux

nfs server:
[root@intel-s3e3144-04 ~]# cat /etc/exports 
/tmp *(rw)
[root@intel-s3e3144-04 ~]# service nfs restart 

[root@intel-s3e3144-04 ~]# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:04:23:C4:7C:DC  
          inet addr:10.66.86.32  Bcast:10.66.87.255  Mask:255.255.254.0
          inet6 addr: 2620:52:0:4257:204:23ff:fec4:7cdc/64 Scope:Global

client:
[root@intel-s3e3144-01 ~]# cat /etc/auto.test 
tmp	intel-s3e3144-04.rhts.eng.nay.redhat.com:/tmp/
[root@intel-s3e3144-01 ~]# cat /etc/auto.master 
...
/test	/etc/auto.test
[root@intel-s3e3144-01 ~]# /etc/init.d/autofs restart
[root@intel-s3e3144-01 ~]# ls -l /test/tmp
total 72
-rw-r--r-- 1 root root  113 Sep 13 02:28 beah-beaker-backend.out
-rw-r--r-- 1 root root   48 Sep 13 02:28 beah-fwd-backend.out
-rw-r--r-- 1 root root   45 Sep 13 02:28 beah-srv.out
-rwx------ 1 root root 8216 Sep 13 02:20 ks-script-MIv2AV
-r-x------ 1 root root 1922 Sep 13 02:28 tmp5U5rbV.sh
-rw------- 1 root root 9611 Sep 13 02:29 tmp.iN3346
-r-x------ 1 root root 1922 Sep 13 02:30 tmpYgB7yr.sh
[root@intel-s3e3144-01 ~]# mount
...
10.66.86.32:/tmp/ on /test/tmp type nfs (rw,addr=10.66.86.32)


Verified on autofs-5.0.1-0.rc2.156.el5_7.1:
[root@intel-s3e3144-01 ~]# rpm -Uvh autofs-5.0.1-0.rc2.156.el5_7.1.i386.rpm 
Preparing...                ########################################### [100%]
   1:autofs                 ########################################### [100%]

[root@intel-s3e3144-01 ~]# ls -l /test/tmp
[root@intel-s3e3144-01 ~]# mount
...
intel-s3e3144-04.rhts.eng.nay.redhat.com:/tmp/ on /test/tmp type nfs (rw,addr=10.66.86.32)


And as per https://errata.devel.redhat.com/errata/show/11098#c29, there are failure of bz130467 and bz248152 caused by bug 706794 which had closed as duplicate with this bug. Now they are passed on new package by regression testing(bz130467 failed on i386 as expected since no server is on the same subnet as the client, other arches are all ok; bz248152 are ok too.) 
https://beaker.engineering.redhat.com/jobs/130794
https://beaker.engineering.redhat.com/jobs/130801
https://beaker.engineering.redhat.com/jobs/130804
https://beaker.engineering.redhat.com/jobs/130805
https://beaker.engineering.redhat.com/jobs/130806

Comment 7 errata-xmlrpc 2011-09-20 07:14:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1318.html


Note You need to log in before you can comment on or make changes to this bug.