Bug 735949 - gimptool-2.0 doesn't observe DESTDIR environment variable (fix the docs, upstream removed it from manpage)
Summary: gimptool-2.0 doesn't observe DESTDIR environment variable (fix the docs, upst...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: alpha
: 6.3
Assignee: Jan Chaloupka
QA Contact: Iveta Wiedermann
URL:
Whiteboard:
Depends On:
Blocks: 1106350
TreeView+ depends on / blocked
 
Reported: 2011-09-06 09:05 UTC by David Jaša
Modified: 2014-10-14 07:25 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 07:25:36 UTC


Attachments (Terms of Use)
DESTDIR removed from man page (700 bytes, patch)
2014-06-05 06:40 UTC, Jan Chaloupka
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1382 normal SHIPPED_LIVE man-pages-overrides bug fix update 2014-10-14 01:21:54 UTC
GNOME Bugzilla 578695 None None None Never

Description David Jaša 2011-09-06 09:05:00 UTC
Description of problem:
SSIA

Version-Release number of selected component (if applicable):
gimp-devel-tools-2.6.9-4.el6_1.1.x86_64

How reproducible:
always

Steps to Reproduce:
1. run:
DESTDIR=/tmp gimptool-2.0 -n --install-admin-script /path/to/script.scm
DESTDIR=/tmp gimptool-2.0 -n --install-admin-bin /path/to/plugin
  
Actual results:
cp /path/to/script.scm /usr/share/gimp/2.6/scripts
cp /path/to/plugin /usr/lib/gimp/2.0/plug-ins

Expected results:
cp /path/to/script.scm /tmp/usr/share/gimp/2.6/scripts
cp /path/to/plugin /tmp/usr/lib/gimp/2.0/plug-ins

Additional info:
Breaks gimptool usage of RPM packaging of gimp .scm scripts

Comment 3 RHEL Product and Program Management 2012-07-10 06:28:40 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 4 RHEL Product and Program Management 2012-07-10 23:17:04 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 11 Jan Chaloupka 2014-06-05 06:40:41 UTC
Created attachment 902413 [details]
DESTDIR removed from man page

Taken from https://git.gnome.org/browse/gimp/plain/docs/gimptool.1.in

Thanks Nils for finding out

Comment 18 errata-xmlrpc 2014-10-14 07:25:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1382.html


Note You need to log in before you can comment on or make changes to this bug.