Bug 735979 - "Rails Error: Unable to access log file " in thin.log
Summary: "Rails Error: Unable to access log file " in thin.log
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-configure
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
Assignee: Mike Orazi
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-06 11:06 UTC by Aziza Karol
Modified: 2012-01-26 12:24 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-07 12:50:08 UTC


Attachments (Terms of Use)

Description Aziza Karol 2011-09-06 11:06:11 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.install aeolus using repo http://repos.fedorapeople.org/repos/aeolus/conductor/testing/fedora-aeolus-testing.repo
2.verify thin.log

 
Actual results:

[root@dell-pe830-01 ~]# tail -f /var/log/aeolus-conductor/thin.log 
>> Writing PID to /var/run/aeolus-conductor/thin.pid
>> Changing process privilege to aeolus:aeolus
Rails Error: Unable to access log file. Please ensure that /usr/share/aeolus-conductor/log/production.log exists and is chmod 0666. The log level has been raised to WARN and the output directed to STDERR until the problem is fixed.
>> Thin web server (v1.2.11 codename Bat-Shit Crazy)




Additional info:
[root@dell-pe830-01 ~]# rpm -qa | grep aeolus
aeolus-conductor-daemons-0.4.0-0.20110901175002git4a3e496.fc15.noarch
rubygem-aeolus-image-0.1.0-3.20110824113236git15b6922.fc15.noarch
aeolus-conductor-0.4.0-0.20110901175002git4a3e496.fc15.noarch
aeolus-configure-2.0.2-2.20110830113535git906f985.fc15.noarch
aeolus-conductor-doc-0.4.0-0.20110901175002git4a3e496.fc15.noarch
aeolus-all-0.4.0-0.20110901175002git4a3e496.fc15.noarch

[root@dell-pe830-01 ~]# cat /etc/issue
Fedora release 15 (Lovelock)
Kernel \r on an \m (\l)

Comment 1 Jan Provaznik 2011-09-14 07:02:28 UTC
In aeolus-conductor init script is log dir set to /var/log/aeolus-conductor/thin.log, so if it's still trying log to log/production.log, it seems to be installation/configuration related bug -> switching to backend team.

Comment 2 wes hayutin 2011-09-22 14:16:07 UTC
[root@unused aeolus-conductor]# cat /var/log/aeolus-conductor/thin.log
>> Writing PID to /var/run/aeolus-conductor/thin.pid
>> Changing process privilege to aeolus:aeolus
Using gem require instead of bundler
>> Thin web server (v1.2.11 codename Bat-Shit Crazy)
>> Maximum connections set to 1024
>> Listening on 127.0.0.1:3000, CTRL+C to stop
[root@unused aeolus-conductor]# 



[root@unused aeolus-conductor]# rpm -qa | grep thin
rubygem-thin-1.2.11-10.fc15.x86_64
[root@unused aeolus-conductor]# rpm -qa | grep aeolus
aeolus-conductor-0.4.0-0.20110921152740gitac47a38.fc15.noarch
rubygem-aeolus-image-0.1.0-3.20110919115936gitd1d24b4.fc15.noarch
aeolus-conductor-daemons-0.4.0-0.20110921152740gitac47a38.fc15.noarch
aeolus-all-0.4.0-0.20110921152740gitac47a38.fc15.noarch
aeolus-configure-2.0.2-4.20110921102958gitcaa9608.fc15.noarch
aeolus-conductor-doc-0.4.0-0.20110921152740gitac47a38.fc15.noarch
[root@unused aeolus-conductor]#


Note You need to log in before you can comment on or make changes to this bug.