Bug 735983 - Error in aeolus-image list --images
Summary: Error in aeolus-image list --images
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: rubygem-aeolus-image
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
Assignee: Matt Wagner
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-06 11:15 UTC by Aziza Karol
Modified: 2014-08-17 22:27 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-07 12:50:18 UTC


Attachments (Terms of Use)

Description Aziza Karol 2011-09-06 11:15:06 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
[root@dell-pe830-01 ~]# aeolus-image list --images  
/usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/abstract_response.rb:48:in `return!': 404 Resource Not Found (RestClient::ResourceNotFound)
	from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/request.rb:220:in `process_result'
	from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/request.rb:169:in `transmit'
	from /usr/lib/ruby/1.8/net/http.rb:543:in `start'
	from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/request.rb:166:in `transmit'
	from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/request.rb:60:in `execute'
	from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/request.rb:31:in `execute'
	from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/resource.rb:54:in `get'
	from /usr/lib/ruby/gems/1.8/gems/aeolus-image-0.1.0/lib/list_command.rb:11:in `images'
	from /usr/lib/ruby/gems/1.8/gems/aeolus-image-0.1.0/lib/config_parser.rb:203:in `send'
	from /usr/lib/ruby/gems/1.8/gems/aeolus-image-0.1.0/lib/config_parser.rb:203:in `list'
	from /usr/lib/ruby/gems/1.8/gems/aeolus-image-0.1.0/lib/config_parser.rb:30:in `send'
	from /usr/lib/ruby/gems/1.8/gems/aeolus-image-0.1.0/lib/config_parser.rb:30:in `process'
	from /usr/lib/ruby/gems/1.8/gems/aeolus-image-0.1.0/bin/aeolus-image:6
	from /usr/bin/aeolus-image:19:in `load'
	from /usr/bin/aeolus-image:19
.
 

Additional info:
[root@dell-pe830-01 ~]# rpm -qa | grep aeolus
aeolus-conductor-daemons-0.4.0-0.20110901175002git4a3e496.fc15.noarch
rubygem-aeolus-image-0.1.0-3.20110824113236git15b6922.fc15.noarch
aeolus-conductor-0.4.0-0.20110901175002git4a3e496.fc15.noarch
aeolus-configure-2.0.2-2.20110830113535git906f985.fc15.noarch
aeolus-conductor-doc-0.4.0-0.20110901175002git4a3e496.fc15.noarch
aeolus-all-0.4.0-0.20110901175002git4a3e496.fc15.noarch

[root@dell-pe830-01 ~]# cat /etc/issue
Fedora release 15 (Lovelock)
Kernel \r on an \m (\l)

Comment 1 wes hayutin 2011-09-22 14:13:59 UTC
need an update from dev on this bug.. has this been reimplemented

Comment 2 Matt Wagner 2011-09-22 17:42:36 UTC
I believe this was fixed in this Conductor commit:

commit a1a298b39043bc45c21414ba67338c7362696d68
Author: Jan Provaznik <jprovazn@redhat.com>
Date:   Tue Sep 20 09:49:35 2011 +0200

    Enabled basic http authentication


However, I'm a little confused because the error we were seeing was a 500, not a 404.

This doesn't look to have made it into our yum repo yet.

Comment 3 Matt Wagner 2011-09-28 15:21:52 UTC
This fix should be in the -testing repo by now.

Comment 5 Aziza Karol 2011-10-03 06:27:13 UTC
The above error is not observed now.

verification details:
[root@ibm-x3150m4-01 aeolus-conductor]# aeolus-image list --images
IMAGE ID     LASTEST PUSHED BUILD     NAME     OS     OS VERSION     ARCH     DESCRIPTION     

[root@ibm-x3150m4-01 templates]# aeolus-image list --images
IMAGE ID                                 LASTEST PUSHED BUILD                     NAME          OS         OS VERSION     ARCH       DESCRIPTION     
007f23b8-f1fa-46c5-83ea-f53e74084301                                              Fedora 15     Fedora     15             x86_64     desc            
a4efe626-9b4f-4f69-a584-3ea3f77f36a9     18222edb-6a56-42e7-a6db-ead1d69a5084     Fedora 15     Fedora     15             x86_64     desc            

[root@ibm-x3150m4-01 templates]# rpm -qa | egrep 'aeolus|imagefactory'
aeolus-conductor-doc-0.4.0-0.20110928134003gitaffcd9c.fc15.noarch
aeolus-configure-2.0.2-4.20110928090214git4df04ad.fc15.noarch
aeolus-conductor-daemons-0.4.0-0.20110928134003gitaffcd9c.fc15.noarch
rubygem-aeolus-image-0.1.0-3.20110919115936gitd1d24b4.fc15.noarch
imagefactory-0.6.2-1.fc15.noarch
rubygem-imagefactory-console-0.5.0-4.20110824113238gitd9debef.fc15.noarch
aeolus-conductor-0.4.0-0.20110928134003gitaffcd9c.fc15.noarch
aeolus-all-0.4.0-0.20110928134003gitaffcd9c.fc15.noarch

Comment 6 Aziza Karol 2011-10-03 14:32:41 UTC
Hi Matt,

I am observing the same issue again.

I did a build, push for ec2,vsphere and executed aeolus-image list --images.  worked fine on the same test machine.

After some time i did a build and push for rhevm and executed aeolus-image list --images. 404 Resource Not Found (RestClient::ResourceNotFound) is observed.

[root@ibm-x3150m4-01 ~]# aeolus-image list --images
/usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/abstract_response.rb:48:in `return!': 404 Resource Not Found (RestClient::ResourceNotFound)
	from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/request.rb:220:in `process_result'
	from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/request.rb:169:in `transmit'
	from /usr/lib/ruby/1.8/net/http.rb:543:in `start'
	from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/request.rb:166:in `transmit'
	from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/request.rb:60:in `execute'
	from /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.1/lib/restclient/request.rb:31:in `execute'
	from /usr/lib/ruby/gems/1.8/gems/aeolus-image-0.1.0/lib/aeolus_image/model/warehouse_client.rb:138:in `do_request'
	from /usr/lib/ruby/gems/1.8/gems/aeolus-image-0.1.0/lib/aeolus_image/model/warehouse_client.rb:43:in `body'
	from /usr/lib/ruby/gems/1.8/gems/aeolus-image-0.1.0/lib/aeolus_image/model/warehouse_client.rb:61:in `attrs'
	from /usr/lib/ruby/gems/1.8/gems/aeolus-image-0.1.0/lib/aeolus_image/model/warehouse_model.rb:70:in `all'
	from /usr/lib/ruby/gems/1.8/gems/aeolus-image-0.1.0/lib/aeolus_image/model/warehouse_model.rb:69:in `map'
	from /usr/lib/ruby/gems/1.8/gems/aeolus-image-0.1.0/lib/aeolus_image/model/warehouse_model.rb:69:in `all'
	from /usr/lib/ruby/gems/1.8/gems/aeolus-image-0.1.0/lib/aeolus_image/command/list_command.rb:25:in `images'
	from /usr/lib/ruby/gems/1.8/gems/aeolus-image-0.1.0/lib/aeolus_image/command/config_parser.rb:211:in `send'
	from /usr/lib/ruby/gems/1.8/gems/aeolus-image-0.1.0/lib/aeolus_image/command/config_parser.rb:211:in `list'
	from /usr/lib/ruby/gems/1.8/gems/aeolus-image-0.1.0/lib/aeolus_image/command/config_parser.rb:38:in `send'
	from /usr/lib/ruby/gems/1.8/gems/aeolus-image-0.1.0/lib/aeolus_image/command/config_parser.rb:38:in `process'
	from /usr/lib/ruby/gems/1.8/gems/aeolus-image-0.1.0/bin/aeolus-image:20
	from /usr/bin/aeolus-image:19:in `load'
	from /usr/bin/aeolus-image:19

[root@ibm-x3150m4-01 ~]# rpm -qa  |  egrep  'aeolus|imagefactory'
aeolus-conductor-doc-0.4.0-0.20110928134003gitaffcd9c.fc15.noarch
aeolus-configure-2.0.2-4.20110928090214git4df04ad.fc15.noarch
aeolus-conductor-daemons-0.4.0-0.20110928134003gitaffcd9c.fc15.noarch
rubygem-aeolus-image-0.1.0-3.20110919115936gitd1d24b4.fc15.noarch
imagefactory-0.6.2-1.fc15.noarch
rubygem-imagefactory-console-0.5.0-4.20110824113238gitd9debef.fc15.noarch
aeolus-conductor-0.4.0-0.20110928134003gitaffcd9c.fc15.noarch
aeolus-all-0.4.0-0.20110928134003gitaffcd9c.fc15.noarch


You can have a look at Test machine:
ibm-x3150m4-01.rhts.eng.bos.redhat.com


Thanks,
Aziza

Comment 7 Matt Wagner 2011-10-03 20:02:46 UTC
Oops, sorry. The repo had apparently not been updated and I missed that. Steve updated it this afternoon and this problem appears to have been fixed, though the machine I'm testing on cannot build images (grr) so I can't be positive.

Comment 8 Aziza Karol 2011-10-04 10:43:52 UTC
The above error is not observed now.

verification details:
IMAGE ID                                 LASTEST PUSHED BUILD                     NAME     OS     OS VERSION     ARCH     DESCRIPTION     
a28bac7b-5215-4bdf-a9b6-748a12493b26                                                                                                      
bce29006-c585-4b8e-8787-c3f7a12e18a7                                                                                                      
7c80deb7-5df4-4f11-b994-628560e2c82b     11e00cab-5dac-4cff-ad37-0f499dea06be                                                             

[root@dell-per905-01 templates]# rpm -qa | egrep 'aeolus|imagefactory'
aeolus-all-0.4.0-0.20111003184622git65a7d19.fc15.noarch
aeolus-conductor-doc-0.4.0-0.20111003184622git65a7d19.fc15.noarch
rubygem-imagefactory-console-0.5.0-4.20110824113238gitd9debef.fc15.noarch
rubygem-aeolus-image-0.1.0-3.20111003170706git8f23238.fc15.noarch
rubygem-aeolus-cli-0.1.0-3.20111003133323git9451323.fc15.noarch
aeolus-configure-2.0.2-4.20110930103205gitaf78594.fc15.noarch
aeolus-conductor-daemons-0.4.0-0.20111003184622git65a7d19.fc15.noarch
imagefactory-0.6.2_11_g7b94a4a-1.fc15.noarch
aeolus-conductor-0.4.0-0.20111003184622git65a7d19.fc15.noarch


Note You need to log in before you can comment on or make changes to this bug.