Bug 735993 - configuring a SCSI cd-rom in an HVM domain messes up IDE drives
Summary: configuring a SCSI cd-rom in an HVM domain messes up IDE drives
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen
Version: 5.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Paolo Bonzini
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 699616
TreeView+ depends on / blocked
 
Reported: 2011-09-06 11:37 UTC by Paolo Bonzini
Modified: 2012-02-21 05:55 UTC (History)
6 users (show)

Fixed In Version: xen-3.0.3-134.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-21 05:55:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0160 normal SHIPPED_LIVE xen bug fix and enhancement update 2012-02-20 14:53:33 UTC

Description Paolo Bonzini 2011-09-06 11:37:02 UTC
When adding a disk with sda:cdrom to an HVM domain, the media type is set on the wrong disk: sda-sdd set the media type on hda-hdd, while from sde on the actual disk is off by 4 (i.e. sde sets it on sda and so on).

This is bad because adding a SCSI cd-rom can make the whole domain unbootable or crash qemu-dm.

* configuration for unbootable domain:

disk = ["file:/var/lib/xen/hvm.img,hda,w", "file:/var/lib/xen/cd.iso,sda:cdrom,r"]
boot = "c"

(hda becomes a CD-ROM and it is excluded from the boot sequence)

* configuration for qemu-dm crash:

disk = ["file:/var/lib/xen/hvm.img,hda,w", "file:/var/lib/xen/cd.iso,sdb:cdrom,r"]

(the hint is set on sdb and this causes a NULL-pointer dereference).

The bug is present since "always".

Comment 2 Miroslav Rezanina 2011-09-07 11:45:36 UTC
Fix built into xen-3.0.3-134.el5

Comment 5 Yuyu Zhou 2011-12-01 03:28:28 UTC
reproduce the bug on xen-3.0.3-132.el5 and verify the bug on xen-3.0.3-135.el5.

on xen-3.0.3-132.el5, 

boot the HVM guest with configure:

disk = ["file:/var/lib/xen/hvm.img,hda,w",
"file:/var/lib/xen/cd.iso,sda:cdrom,r"]
boot = "c"

In fact, no guest is created.

boot the HVM guest with configure:

disk = ["file:/var/lib/xen/hvm.img,hda,w",
"file:/var/lib/xen/cd.iso,sdb:cdrom,r"]

the guest fail to boot.

on xen-3.0.3-135.el5:
boot the guest with both configure will succeed, and the content of iso can be seen in the guest.

So change the bug to VERIFIED.

Comment 6 errata-xmlrpc 2012-02-21 05:55:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0160.html


Note You need to log in before you can comment on or make changes to this bug.