Bug 73600 - X login dialog: translated button labels are missing.
X login dialog: translated button labels are missing.
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gdm (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
Mike McLean
: Triaged
: 80325 (view as bug list)
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2002-09-06 12:13 EDT by Eugene Kanter
Modified: 2007-04-18 12:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-20 10:45:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ru_RU.UTF-8: GIMP Tip of the Day (10.50 KB, image/png)
2002-09-06 17:51 EDT, Eugene Kanter
no flags Details

  None (edit)
Description Eugene Kanter 2002-09-06 12:13:39 EDT
Description of Problem:

Translated labels "> Language", "> Session" and "> System" in the low left
corner are empty, only three ">" are visible next to each other if system
language is ru_RU.UTF-8. The rest of the screen is properly translated.

Version-Release number of selected component (if applicable):

update null.

How Reproducible:

always

Steps to Reproduce:
1. default install, select Russian in the list of included languages.
2. set Russian default or edit /etc/sysconfig/i18n by hand and set LANG=ru_RU.UTF-8
3. set runlevel 5

Actual Results:

translated labels are missing buttons have only "> " on them.

Expected Results:

Buttons with translated labels
Comment 1 Havoc Pennington 2002-09-06 12:30:25 EDT
Confirmed, this is pretty strange. The translations in the theme file look good, 
they are valid UTF-8 and look like Russian to me. Maybe a problem with missing
font glyphs...
Comment 2 Eugene Kanter 2002-09-06 13:27:36 EDT
But the date/time shows up fine. Does the button label use different font?
Comment 3 Eugene Kanter 2002-09-06 17:48:13 EDT
There is a similar behavior in gimp tips dialog. See attached. The fonts where
there are no cyrillic glyphs show up as a square. But tips text does no show up
at all. Not even as squares. This gimp problem only happens in UTF-8. However
switching system language to ru_RU.KOI8-R does not fix login screen.
Comment 4 Eugene Kanter 2002-09-06 17:51:13 EDT
Created attachment 75364 [details]
ru_RU.UTF-8: GIMP Tip of the Day
Comment 5 Leonid Kanter 2002-12-13 18:20:00 EST
This problem is still present in 8.0.91
Comment 6 Havoc Pennington 2002-12-19 20:08:28 EST
We should try experimenting with changing the font for that text 
in the theme file in /usr/share/gdm/themes/Bluecurve
Comment 7 Havoc Pennington 2002-12-24 13:26:11 EST
*** Bug 80325 has been marked as a duplicate of this bug. ***
Comment 8 Nikos Charonitakis 2002-12-24 16:53:29 EST
i ve noticed in /usr/share/gdmt/themes/bluecururve  that bluecurve use sans font.
unfortunately these fonts has not support to greek character set (greek users
under linux mainly use msft fonts and some other low quality free fonts)
So i ve tried to change san to other fonts (msft) but didnt worked (may be i did
it wrong way- i edited bluecurve.xml.in replacing sans bold 21 with albany).
The problem remained the same but with albany fonts.

e.g

Is it possible you add support for the greek characters in sans fonts?
it will be great  for greek redhat users.  :)

Nikos
Comment 9 Havoc Pennington 2002-12-24 17:27:19 EST
We'd certainly take changes to add greek support to Sans-serif (or better, 
send the changes to Keith Packard for inclusion in fontconfig - keithp@keithp.com)

My understanding was that we don't have any greek fonts in the distribution, though.
Comment 10 Owen Taylor 2003-01-16 16:04:35 EST
Note on the offtopic part:

(monotonic) Greek will work fine if you have the fonts.

The common set of free TrueType Greek fonts is:

 - Rather low quality outlines
 - Named using trademarked names
 - Of questionable origin

So it's not really shippable. I have some plans to convert the
OmegaSerifGreek font we ship as part of TeX into a usable form.

The FreeFront project (http://savannah.nongnu.org/download/freefont/)
includes Greek, you might want to install that. (There are some format
issues that make it undesirable for inclusion in Red Hat.)
Comment 11 Owen Taylor 2003-01-16 16:14:20 EST
Taking GDM target/blockers.
Comment 12 Owen Taylor 2003-01-16 18:58:00 EST
The login screen works fine with current packages (aside for some strings
that aren't yet translated... redhat-artwork was just added to i18n.redhat.com
and needs some work for Russian)

The GIMP tips problem is presumably a dup of bug 68725 (which, BTW, is
a quick fix for a motivated person to do and test out.)
Comment 13 Leonid Kanter 2003-01-20 08:50:52 EST
In latest phoebe gdm-2.4.1.0-1 is still broken. Greeting string (translation of
Welcome to...) and menu items are shown as non-interpreted utf, while
translation of "enter your name" and date are OK.
Comment 14 Owen Taylor 2003-01-20 10:45:26 EST
The raw UTF-8 you are seeing is something different... a problem
with intltool generating incorrect output for the Bluecurve GDM
theme in redhat-artwork. There should be another bug open about
that though I dont' know the bug # offhand.


Note You need to log in before you can comment on or make changes to this bug.