Bug 736033 - /etc/dbus-1/system.conf from dbus.i386 conflicts with the same file from dbus.x86_64
Summary: /etc/dbus-1/system.conf from dbus.i386 conflicts with the same file from dbus...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dbus
Version: 5.7
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Richard Hughes
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-06 13:25 UTC by manuel wolfshant
Modified: 2015-10-05 11:27 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:24:10 UTC


Attachments (Terms of Use)
file /etc/dbus-1/system.conf from install of dbus-1.1.2-21.el5.i386 conflicts with file from package dbus-1.1.2-21.el5.x86_64 (1.75 KB, text/plain)
2015-03-22 14:05 UTC, Dan Scherer
no flags Details

Description manuel wolfshant 2011-09-06 13:25:59 UTC
Description of problem:
dbus.i386 and dbus.x86_64 comflict

Version-Release number of selected component (if applicable):
dbus-1.1.2-15.el5_6
dbus-1.1.2-16.el5_7

How reproducible:
Always

Steps to Reproduce:
1. yum install dbus.i386 on an x86_64 machine
  
Actual results:
  file /etc/dbus-1/system.conf from install of dbus-1.1.2-16.el5_7.i386 conflicts with file from package dbus-1.1.2-16.el5_7.x86_64

Expected results:
either no conflict or an explicit Conflicts: in the spec

Additional info:
A diff between the two config files gives:
<   <servicehelper>/lib64/dbus-1/dbus-daemon-launch-helper</servicehelper>
---                                                                       
>   <servicehelper>/lib/dbus-1/dbus-daemon-launch-helper</servicehelper>  

so there is a real difference over there.

Comment 1 Akemi Yagi 2011-09-06 21:38:12 UTC
According to bug #666527, dbus.i386 is supposed to have been removed from the x86_64 repositories in RHEL 5.7. But it is still there, thus causing the conflict reported here.

Comment 2 SriniG 2011-10-27 15:51:33 UTC
$ sudo rpm -Fvh --repackage *.rpm --nodeps --test
warning: dbus-1.1.2-16.el5_7.i386.rpm: Header V3 DSA signature: NOKEY, key ID 37017186
Preparing...                ########################################### [100%]
        file /etc/dbus-1/system.conf from install of dbus-1.1.2-16.el5_7.i386 conflicts with file from package dbus-1.1.2-15.el5_6.x86_64

$ uname -m
x86_64


$ sudo rpm -Fvh --repackage dbus-1.1.2-16.el5_7.x86_64.rpm
warning: dbus-1.1.2-16.el5_7.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 37017186
error: Failed dependencies:
        dbus-libs = 1.1.2-16.el5_7 is needed by dbus-1.1.2-16.el5_7.x86_64

$ rpm -qa | grep dbus
dbus-libs-1.1.2-15.el5_6
dbus-python-0.70-7.el5
dbus-glib-0.73-10.el5_5
dbus-glib-0.73-10.el5_5
dbus-1.1.2-15.el5_6
dbus-1.1.2-15.el5_6
dbus-libs-1.1.2-15.el5_6

$ sudo rpm -Fvh --repackage dbus-1.1.2-16.el5_7.x86_64.rpm --nodeps
warning: dbus-1.1.2-16.el5_7.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 37017186
Preparing...                ########################################### [100%]
        file /etc/dbus-1/system.conf from install of dbus-1.1.2-16.el5_7.x86_64 conflicts with file from package dbus-1.1.2-15.el5_6.i386
[gulls8@usccqtd002bhpr2 dbus5]$

Comment 3 Akemi Yagi 2012-02-27 16:58:37 UTC
Still there in RHEL 5.8. dbus.i386 should have been removed earlier (bug #666527).

$ cat /etc/redhat-release
Red Hat Enterprise Linux Server release 5.8 (Tikanga)

$ sudo yum list dbus
Installed Packages
dbus.x86_64                  1.1.2-16.el5_7          installed
Available Packages
dbus.i386                    1.1.2-16.el5_7          rhel-x86_64server-5

Comment 4 Neel Patel 2013-12-30 09:56:21 UTC
I am also getting the same problem.

Getting below error while download dbus.i386 ( yum install dbus.i386 ) in 64 bit machine.

Transaction Check Error:
  file /etc/dbus-1/system.conf from install of dbus-1.1.2-21.el5.i386 conflicts with file from package dbus-1.1.2-21.el5.x86_64


Can you please suggest what is the solution to this problem ?

Comment 5 RHEL Product and Program Management 2014-03-07 13:57:19 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 6 RHEL Product and Program Management 2014-06-02 13:24:10 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Comment 7 Dan Scherer 2015-03-22 14:05:31 UTC
Created attachment 1005057 [details]
file /etc/dbus-1/system.conf from install of dbus-1.1.2-21.el5.i386 conflicts with file from package dbus-1.1.2-21.el5.x86_64

I am see this issues in Red Hat Enterprise Linux Server release 5.11 I have read some articles where they say this was suppose to be gone in 5.7. I also read some responses that folks just use the force command to have it installed.  What is the the best/correct way to resolve this error?


Note You need to log in before you can comment on or make changes to this bug.