Bug 73604 - lam requires libaio.so.1 but really needs libaio.so
Summary: lam requires libaio.so.1 but really needs libaio.so
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: lam   
(Show other bugs)
Version: null
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-06 16:29 UTC by Michael Young
Modified: 2007-04-18 16:46 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-06 19:35:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Young 2002-09-06 16:29:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826

Description of problem:
If you have the lam and libaio packages installed, but not libaio-devel, then
hf77 returns the error
/usr/bin/ld: cannot find -laio
collect2: ld returned 1 exit status
The problem is that although libaio.so.1 is in the requires list for lam (which
is provided by the libaio package), hf77 actually looks for libaio.so - a
symbolic link to libaio.so.1, which is in the libaio-devel package.
Either the requirements of the lam package should be changed, or the libaio and
libaio-devel packages should be reorganized.

Comment 1 Trond Eivind Glomsrxd 2002-09-06 16:58:05 UTC
"libaio-devel" (with the .so for linking) is needed to compile programs, not to
run lam. Same with gcc-g77 - if you're going to compile, and not have it be a
node, you need all the libraries/programs you'll use to create that program.

Comment 2 Michael Young 2002-09-06 18:20:47 UTC
That would be fair enough if you got the option not to use the aio library, but
you don't - it is added automatically. You need libaio-devel to use hf77 at all,
even if you are only building a hello world program. Try it!

Comment 3 Trond Eivind Glomsrxd 2002-09-06 19:08:49 UTC
It's optional for running a program. It's in the same category as a complete set
of compilers, glibc-devel, libstdc++-devel etc. if you use it to build programs
- and you'll notice that e.g. gcc doesn't require all the "-devel" packages in
the distribution even though you could get the same compile errors you're seeing
with it.

Comment 4 Michael Young 2002-09-06 19:35:42 UTC
I wouldn't expect gcc to require all the -devel packages in the distribution,
but I would expect it to require any -devel packages that are needed even to
compile the simplest of programs, which is the case with hf77 and libaio-devel.


Note You need to log in before you can comment on or make changes to this bug.