Bug 736082 - virt-manager: guest startup fails if /dev/sr0 empty?
Summary: virt-manager: guest startup fails if /dev/sr0 empty?
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 15
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-06 15:58 UTC by melchiaros
Modified: 2012-10-15 22:25 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-29 20:20:01 UTC


Attachments (Terms of Use)
message and libvirt logs (816.51 KB, application/x-gzip)
2011-09-06 16:01 UTC, melchiaros
no flags Details

Description melchiaros 2011-09-06 15:58:30 UTC
Description of problem:
I´ve installed yesterday a windowsXPSP2 guest and upgraded it to SP3.
Today I want to start with virt-manager the windows XP guest and get from virt-manager and error message:

Error starting domain: unable to open disk path /dev/sr0: Kein Medium gefunden

It is not able to find the .raw anymore, but it is still in it´s folder like yesterday.
-> I´ve installed in not in root. Instead in /home/user/Vorlagen/windowsXP_old.raw

That may cause the problem. But for my linux guest it works.-> Only windows iis affected with this.

Version-Release number of selected component (if applicable):

[user@localhost ~]$ rpm -qa | grep virt-manager
virt-manager-0.8.7-4.fc15.noarch
[user@localhost ~]$ rpm -qa | grep kvm
qemu-kvm-0.14.0-7.fc15.x86_64
^[[A[user@localhost rpm -qa | grep qemu
gpxe-roms-qemu-1.0.1-4.fc15.noarch
qemu-system-x86-0.14.0-7.fc15.x86_64
qemu-kvm-0.14.0-7.fc15.x86_64
qemu-common-0.14.0-7.fc15.x86_64
qemu-img-0.14.0-7.fc15.x86_64
[user@localhost ~]$ rpm -qa | grep kernel
arm-gp2x-linux-kernel-headers-2.6.12.0-5.fc15.noarch
abrt-addon-kerneloops-2.0.3-1.fc15.x86_64
kernel-debug-2.6.40.3-0.fc15.x86_64
kernel-2.6.38.6-26.rc1.fc15.x86_64
kernel-devel-2.6.40.3-0.fc15.x86_64
kernel-headers-2.6.40.3-0.fc15.x86_64
kernel-2.6.40.3-0.fc15.x86_64
[user@localhost ~]$ rpm -qa | grep libvirt
libvirt-0.8.8-7.fc15.x86_64
libvirt-python-0.8.8-7.fc15.x86_64
libvirt-client-0.8.8-7.fc15.x86_64


How reproducible:
Always there.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Not working guest

Expected results:

Guest should work.
Additional info:

Comment 1 melchiaros 2011-09-06 16:01:23 UTC
Created attachment 521703 [details]
message and libvirt logs

Comment 2 Cole Robinson 2011-09-26 15:43:30 UTC
Hmm, empty /dev/sr0 shouldn't cause qemu to fail to start... I'll try and reproduce

Comment 3 Cole Robinson 2012-01-29 20:20:01 UTC
I can't reproduce this issue. If you can still reproduce, please reopen, and provide the output of following commands for the busted VM

sudo virsh --connect qemu:///system start <vmname>
sudo virsh --connect qemu:///system dumpxml <vmname>

also, does the following command produce a similar error:

qemu-kvm -cdrom /dev/sr0


Note You need to log in before you can comment on or make changes to this bug.