Bug 736093 - Promotions: Expanding Help text causes tupane to render incorrectly when package info is open
Summary: Promotions: Expanding Help text causes tupane to render incorrectly when pack...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-09-06 16:28 UTC by Corey Welton
Modified: 2019-09-26 13:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:55:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (133.40 KB, image/png)
2011-09-06 16:32 UTC, Corey Welton
no flags Details

Description Corey Welton 2011-09-06 16:28:10 UTC
Description of problem:


Version-Release number of selected component (if applicable):
When user is in Promotions and viewing info for a package, clicking the helptext at the top of the view causes the right tupane window to wander.

How reproducible:


Steps to Reproduce:
1.  Sync some content 
2.  Navigate to Content > Promotions
3.  Click some package to get package info.
4.  While package info is open, expand the helptext box at the top of the view
  
Actual results:
Right tupane shifts unexpectedly

Expected results:
Normal rendering

Additional info:

Comment 1 Corey Welton 2011-09-06 16:31:42 UTC
Note: if helptext is already expanded when page is loaded, this will not occur. Furthermore, even if user closes the helptext and attempts these steps, it will not occur.  It only seems to happen when page is initially loaded with a minimized helptext.

Comment 2 Corey Welton 2011-09-06 16:32:06 UTC
Created attachment 521710 [details]
screenshot

Comment 3 Eric Helms 2011-09-27 14:33:08 UTC
commit c483fdca016714bbfce52a556ea8b15a7b4cb5a6

This commit should make it so that opening and closing the helptip will adjust the height of the normal slide out tupanel and sliding tree implementations such as the promotions page as to not overlap the helptip.

Comment 4 Corey Welton 2011-10-25 03:58:30 UTC
QA Verified

Comment 7 Mike McCune 2013-08-16 18:08:48 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.