Bug 736096 - "Show Launcher when it's not running" option doesn't pin launcher to taskbar
Summary: "Show Launcher when it's not running" option doesn't pin launcher to taskbar
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kde-plasma-smooth-tasks
Version: 16
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Sven Lankes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-06 16:37 UTC by Nikolai Maziashvili
Modified: 2012-09-16 19:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-09-16 19:37:56 UTC


Attachments (Terms of Use)
Screenshot of a pinned task (54.60 KB, image/png)
2012-05-29 12:55 UTC, Martin Bříza
no flags Details

Description Nikolai Maziashvili 2011-09-06 16:37:50 UTC
Description of problem:
When application launched it appears in taskbar (if present of course) on the panel. When right clicked on application icon in the taskbar and scrolled to "Advanced" field there is a option that can pin/show that particular application on the taskbar even when application is not running.
This option is present not only in "smooth-tasks" plasma addon, but in default taskbar too.
In neither this option delivers suggested results. 

Version-Release number of selected component (if applicable):
kde-plasma-smooth-tasks v 0.0.1-0.2.wip20101106.fc15
kdebase 4.7.0-1fc15

How reproducible:


Steps to Reproduce:
1. open (for example) dolphin
2. right click on dolphin icon on taskbar
3. go to "Advanced" and select "Show a Launche for Dolphin When It Is not running"
4. close dolphin
  
Actual results:
taskbar is empty

Expected results:
Dolphin icon on taskbar

Additional info:

Comment 1 Nikolai Maziashvili 2011-12-05 22:35:14 UTC
F16 ... still present.

Comment 2 Martin Bříza 2012-05-29 12:55:21 UTC
Created attachment 587399 [details]
Screenshot of a pinned task

I tried this and pinning an application to both default taskbar and smooth tasks works for me... 
By the way, on this screenshot, I pinned the calculator once on both of the bars. One bar does not affect the other.

Comment 3 Nikolai Maziashvili 2012-09-16 19:37:56 UTC
solved in KDE 4.9. Well unlike in Martin case it didn't worked for me untill now. Closing this one...


Note You need to log in before you can comment on or make changes to this bug.