Bug 736112 - tdb-tools subpackage conflicts with samba
tdb-tools subpackage conflicts with samba
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libtdb (Show other bugs)
5.7
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Stephen Gallagher
Jenny Galipeau
:
: 765887 (view as bug list)
Depends On: 739502
Blocks: 784526
  Show dependency treegraph
 
Reported: 2011-09-06 14:03 EDT by manuel wolfshant
Modified: 2014-06-11 06:57 EDT (History)
13 users (show)

See Also:
Fixed In Version: libtdb-1.2.1-7.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 23:09:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description manuel wolfshant 2011-09-06 14:03:29 EDT
Description of problem:
The tdb-tools subpackage contains binaries and manpages that are also provided
by the samba package.


Version-Release number of selected component (if applicable):
1.2.1-6.el5

How reproducible:
Always

Steps to Reproduce:
1. Install samba
2. Attempt to install tdb-tools
  
Actual results:
Transaction Check Error:
  file /usr/bin/tdbbackup from install of tdb-tools-1.2.1-6.el5.x86_64 conflicts with file from package samba-3.0.33-3.29.el5_6.2.x86_64                                                            
  file /usr/bin/tdbdump from install of tdb-tools-1.2.1-6.el5.x86_64 conflicts with file from package samba-3.0.33-3.29.el5_6.2.x86_64                                                              
  file /usr/bin/tdbtool from install of tdb-tools-1.2.1-6.el5.x86_64 conflicts with file from package samba-3.0.33-3.29.el5_6.2.x86_64                                                              
  file /usr/share/man/man8/tdbbackup.8.gz from install of tdb-tools-1.2.1-6.el5.x86_64 conflicts with file from package samba-3.0.33-3.29.el5_6.2.x86_64                                            
  file /usr/share/man/man8/tdbdump.8.gz from install of tdb-tools-1.2.1-6.el5.x86_64 conflicts with file from package samba-3.0.33-3.29.el5_6.2.x86_64                                              
  file /usr/share/man/man8/tdbtool.8.gz from install of tdb-tools-1.2.1-6.el5.x86_64 conflicts with file from package samba-3.0.33-3.29.el5_6.2.x86_64                                              



Expected results:
Either samba should not conflict with tdb-tools or libtdb should be made to explicitely conflict with samba

Additional info:
It's essentially the same bug as https://bugzilla.redhat.com/show_bug.cgi?id=577902 only that since RHEL 5.6 libtdb has been imported as a core package
Comment 1 Akemi Yagi 2011-09-07 12:56:07 EDT
I can confirm the issue on an up-to-date RHEL 5.7 system:

$ sudo yum install tdb-tools

Transaction Check Error:
  file /usr/bin/tdbbackup from install of tdb-tools-1.2.1-6.el5.i386 conflicts with file from package samba-3.0.33-3.29.el5_7.4.i386
  file /usr/bin/tdbdump from install of tdb-tools-1.2.1-6.el5.i386 conflicts with file from package samba-3.0.33-3.29.el5_7.4.i386
  file /usr/bin/tdbtool from install of tdb-tools-1.2.1-6.el5.i386 conflicts with file from package samba-3.0.33-3.29.el5_7.4.i386
  file /usr/share/man/man8/tdbbackup.8.gz from install of tdb-tools-1.2.1-6.el5.i386 conflicts with file from package samba-3.0.33-3.29.el5_7.4.i386
  file /usr/share/man/man8/tdbdump.8.gz from install of tdb-tools-1.2.1-6.el5.i386 conflicts with file from package samba-3.0.33-3.29.el5_7.4.i386
  file /usr/share/man/man8/tdbtool.8.gz from install of tdb-tools-1.2.1-6.el5.i386 conflicts with file from package samba-3.0.33-3.29.el5_7.4.i386
Comment 2 Stephen Gallagher 2011-09-07 13:03:09 EDT
Redirecting this bug to the samba component. The samba package needs to be updated to build against the system libtdb.
Comment 3 Guenther Deschner 2011-09-08 07:10:50 EDT
The 3.0.33 samba version does not allow to link against a system libtdb easily, it would require a lot of work to make this possible. What we could do is to remove those conflicting files and require tdb-tools installed from the samba package. Simo, would there be potential issues using recent tdb-tools against old tdb files (generated from the old tdb copy out of the samba 3.0.33 build) ?
Comment 4 Simo Sorce 2011-09-08 08:29:28 EDT
In theory the file format is stable so using newer tools shouldn't cause issues. But it would need at least a smoke test to make sure.
Comment 7 RHEL Product and Program Management 2011-09-22 20:27:53 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 Stephen Gallagher 2011-12-12 08:09:50 EST
*** Bug 765887 has been marked as a duplicate of this bug. ***
Comment 9 RHEL Product and Program Management 2011-12-13 03:57:12 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 22 Amith 2012-07-25 12:13:56 EDT
Verified the bug on libtdb-1.2.10-1.el5 and tdb-tools-1.2.10-1.el5.

Bug was verified by installing samba and then subsequent installation of tdb-tools. Conflicts were not found.

 # yum install samba

Loaded plugins: product-id, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package samba.x86_64 0:3.0.33-3.39.el5_8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved
==============================================================================
 Package       Arch        Version         Repository       Size
==============================================================================
Installing:
 samba        x86_64   3.0.33-3.39.el5_8  beaker-Server     16 M

Transaction Summary
==============================================================================
Install       1 Package(s)
Upgrade       0 Package(s)

Total download size: 16 M
Is this ok [y/N]: y
Downloading Packages:

samba-3.0.33-3.39.el5_8.x86_64.rpm                      |  16 MB     00:11     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : samba                                                1/1 

Installed:
  samba.x86_64 0:3.0.33-3.39.el5_8                                             

Complete!

 # yum install tdb-tools

Loaded plugins: product-id, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package tdb-tools.x86_64 0:1.2.10-1.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================
 Package     Arch      Version        Repository               Size
==============================================================================
Installing:
 tdb-tools  x86_64   1.2.10-1.el5    beaker-Server             28 k

Transaction Summary
=============================================================================
Install       1 Package(s)
Upgrade       0 Package(s)

Total download size: 28 k
Is this ok [y/N]: y
Downloading Packages:
tdb-tools-1.2.10-1.el5.x86_64.rpm                        |  28 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : tdb-tools                                          1/1 

Installed:
  tdb-tools.x86_64 0:1.2.10-1.el5                                              

Complete!
Comment 24 errata-xmlrpc 2013-01-07 23:09:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0016.html

Note You need to log in before you can comment on or make changes to this bug.