Bug 736149 - dhclient coredumps when the system has interface with NULL ifa_addr
Summary: dhclient coredumps when the system has interface with NULL ifa_addr
Keywords:
Status: CLOSED DUPLICATE of bug 731990
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dhcp
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jiri Popelka
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-06 19:58 UTC by Konstantin Volkov
Modified: 2011-09-07 08:59 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-07 08:59:35 UTC


Attachments (Terms of Use)

Description Konstantin Volkov 2011-09-06 19:58:00 UTC
Description of problem:

dhclient coredumps when the system has interface with NULL ifa_addr

---
[root@localhost ~]# ifconfig venet0
venet0    Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          BROADCAST POINTOPOINT NOARP  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
[root@localhost client]# gdb --args ./dhclient eth0
GNU gdb (GDB) Red Hat Enterprise Linux (7.2-48.el6)
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /root/rpmbuild/BUILD/dhcp-4.1.1-P1/client/dhclient...done.
(gdb) run
Starting program: /root/rpmbuild/BUILD/dhcp-4.1.1-P1/client/dhclient eth0
Detaching after fork from child process 32611.
-1207741920 -1207741892
-1207741764 0

Program received signal SIGSEGV, Segmentation fault.
0xb7fb1c0f in get_hw_addr (info=0xb800c608) at lpf.c:639
---

the similar BUG: https://bugzilla.redhat.com/show_bug.cgi?id=731999

after this patch:

---
[root@localhost dhcp-4.1.1-P1]# diff -u ./common/lpf.c.orig ./common/lpf.c
--- ./common/lpf.c.orig 2011-09-06 23:49:26.000000000 +0400
+++ ./common/lpf.c      2011-09-06 23:49:48.000000000 +0400
@@ -634,6 +634,9 @@
 
        for (ifa = ifaddrs; ifa != NULL; ifa = ifa->ifa_next) {
 
+               if (ifa->ifa_addr == NULL)
+                       continue;
+
                if (ifa->ifa_addr->sa_family != AF_PACKET)
                        continue;
 

---

All is OK

Version-Release number of selected component (if applicable):

dhcp-4.1.1-19.P1.el6

How reproducible:

100%

Steps to Reproduce:
1. Run dhclient eth0 inside Virtuozzo or OpenVZ Container
2. Get the SegFault
  
Actual results:

SegFault

Expected results:

No SegFault, eth0 get the IP

Please fix.

Comment 2 Jiri Popelka 2011-09-07 08:59:35 UTC
Thank you for the report.
This is duplicate of bug #731990 which would be fixed in forthcoming RHEL-6.2.

*** This bug has been marked as a duplicate of bug 731990 ***


Note You need to log in before you can comment on or make changes to this bug.