Bug 73615 - Service manager blocked signals cause user service scripts to fail
Service manager blocked signals cause user service scripts to fail
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: clumanager (Show other bugs)
2.1
All Linux
high Severity high
: ---
: ---
Assigned To: Lon Hohberger
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-06 15:15 EDT by Lon Hohberger
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-06 15:16:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example of how to break 1.0.11 during 'service start'. (172 bytes, text/plain)
2002-09-06 16:04 EDT, Lon Hohberger
no flags Details

  None (edit)
Description Lon Hohberger 2002-09-06 15:15:56 EDT
Description of Problem:
When clustering certain applications which use signals to synchronize or
communicate with eachother, the tasks fail to run properly because the service
manager spawns them with most or all signals blocked.


Version-Release number of selected component (if applicable):
1.0.11, CVS/Development


How Reproducible: Every Time


Steps to Reproduce:
1. Create a process which goes to sleep and uses SIGALARM to wake itself up. 
Have it wait forever until SIGALARM is called.
2. Create a service script which spawns this process in the "start" path.
3. Create a service which uses this script.
4. Attempt to enable the service.  Watch the service script hang.

Actual Results:
Hung service start/Application broken.


Expected Results:
Clean service start.
Comment 1 Lon Hohberger 2002-09-06 15:16:36 EDT
I will fix this ASAP.
Comment 2 Lon Hohberger 2002-09-06 16:01:55 EDT
Fix in pool.
Comment 3 Lon Hohberger 2002-09-06 16:04:02 EDT
Created attachment 75324 [details]
Example of how to break 1.0.11 during 'service start'.

Note You need to log in before you can comment on or make changes to this bug.