Bug 736166 - need certificates from subscription-manager rpm pulled into python-rhsm
need certificates from subscription-manager rpm pulled into python-rhsm
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-rhsm (Show other bugs)
6.2
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Chris Duryee
:
Depends On:
Blocks: rhsm-rhel62 734478 743047
  Show dependency treegraph
 
Reported: 2011-09-06 17:28 EDT by Perry Myers
Modified: 2011-12-06 12:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:26:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2011-09-06 17:28:27 EDT
Description of problem:
For using python-rhsm to register with Hosted candlepin, we need the following certificates to connect:

/etc/rhsm/ca/candlepin-stage.pem
/etc/rhsm/ca/fakamai-cp1.pem
/etc/rhsm/ca/redhat-uep.pem

These certs are in the subscription-manager rpm, but RHEVH doesn't need that rpm (and it pulls in deps like yum, which we also can't use).  So it would be better to move these from s-m to python-rhsm
Comment 1 Chris Duryee 2011-09-07 16:12:11 EDT
0507fb7a6103963f8f9ed4f9e0bb8a934f517124 python-rhsm master 0.96.12+
983fb44fccbf3977ca1ca5d9557503432b791cc5 sub-mgr master 0.96.11+
Comment 3 John Sefler 2011-09-23 10:25:27 EDT
Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q python-rhsm subscription-manager
python-rhsm-0.96.12-1.el6.noarch
subscription-manager-0.96.11-1.el6.x86_64

[root@jsefler-onprem-62server ~]# rpm -ql python-rhsm | grep .pem
/etc/rhsm/ca/candlepin-stage.pem
/etc/rhsm/ca/redhat-uep.pem
[root@jsefler-onprem-62server ~]# rpm -ql subscription-manager | grep .pem
[root@jsefler-onprem-62server ~]# 

^^^ Notice the ca certificates are now delivered with the python-rhsm and not the subscription-manager package.

Also note that the /etc/rhsm/ca/fakamai-cp1.pem certificate was removed.  This was really used as part of a test environment and is not necessary in the stage/production environment.
Comment 4 errata-xmlrpc 2011-12-06 12:26:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1696.html

Note You need to log in before you can comment on or make changes to this bug.