Bug 736168 - JOPR 2.3.1 upgrade to RHQ 4.1.1 fails (oracle as repo)
Summary: JOPR 2.3.1 upgrade to RHQ 4.1.1 fails (oracle as repo)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: RHQ Project
Classification: Other
Component: Installer
Version: 4.1
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: ---
: ---
Assignee: Charles Crouch
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks: 720674
TreeView+ depends on / blocked
 
Reported: 2011-09-06 21:28 UTC by Mike Foley
Modified: 2015-02-01 23:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-26 18:48:40 UTC


Attachments (Terms of Use)
RHQ Server log of upgrade failure (69.99 KB, application/octet-stream)
2011-09-06 21:28 UTC, Mike Foley
no flags Details
image of error (68.68 KB, image/png)
2011-09-06 21:29 UTC, Mike Foley
no flags Details
rhq-installer-dbupgrade.log (83.90 KB, application/octet-stream)
2011-09-06 21:29 UTC, Mike Foley
no flags Details

Description Mike Foley 2011-09-06 21:28:39 UTC
Created attachment 521765 [details]
RHQ Server log of upgrade failure

Description of problem:  JOPR 2.3.1 upgrade to RHQ 4.1.1 fails (oracle as repo)


Version-Release number of selected component (if applicable):
JOPR 2.3.1 final to RHQ 4.1.1



Steps to Reproduce:
1.  install JOPR 2.3.1.  use oracle repo.
2.  upgrade to RHQ 4.1
3.  observe failure (see attachments)
  
Actual results:
failed upgrade.

Expected results:
successful upgrade.

Additional info:
attachments

Comment 1 Mike Foley 2011-09-06 21:29:10 UTC
Created attachment 521766 [details]
image of error

Comment 2 Mike Foley 2011-09-06 21:29:53 UTC
Created attachment 521767 [details]
rhq-installer-dbupgrade.log

Comment 7 Mike Foley 2011-09-26 18:32:03 UTC
this BZ was invalid, based on pilot error.  improper cleaning of the database.  the (incorrect) assumption was that a SQL script used to drop all tables with cascade constraints cleaned the database.  this assumption proved invalid because sequences were not deleted.  the existing sequence is in the logs attached to this BZ.  schema changes are covered by the  existing jenkins job ... https://hudson.qa.jboss.com/hudson/view/RHQ%20Core/job/rhq-master-ora-dbupgrade/  
...which is passing now, and was passing at the time this BZ was logged on 9/6.


Note You need to log in before you can comment on or make changes to this bug.