Bug 736231 - Loading internal snapshot causing image corrupted
Summary: Loading internal snapshot causing image corrupted
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.2
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Kevin Wolf
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-07 06:13 UTC by Qunfang Zhang
Modified: 2013-05-17 15:39 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-17 15:39:07 UTC


Attachments (Terms of Use)

Description Qunfang Zhang 2011-09-07 06:13:01 UTC
Description of problem:
Boot a guest and save a internal snapshot, and then loading the snapshot. The guest image got corrupted.

# qemu-img check RHEL6.2-64.qcow2 

ERROR OFLAG_COPIED: offset=80000001998d0000 refcount=2
ERROR OFLAG_COPIED: offset=80000001998e0000 refcount=2
ERROR OFLAG_COPIED: offset=80000001998f0000 refcount=2
ERROR OFLAG_COPIED: offset=8000000199900000 refcount=2
ERROR OFLAG_COPIED: offset=8000000199910000 refcount=2
ERROR OFLAG_COPIED: offset=8000000199920000 refcount=2
ERROR OFLAG_COPIED: offset=8000000199930000 refcount=2
ERROR OFLAG_COPIED: offset=8000000199940000 refcount=2
ERROR OFLAG_COPIED: offset=8000000199950000 refcount=2
ERROR OFLAG_COPIED: offset=8000000199960000 refcount=2
ERROR OFLAG_COPIED: offset=8000000199970000 refcount=2
ERROR OFLAG_COPIED: offset=8000000199980000 refcount=2
..........

Test with the steps in bug 729572, no error. File this bug as the error messages are different as bug 729572.

Version-Release number of selected component (if applicable):
kernel-2.6.32-195.el6.x86_64
qemu-kvm-0.12.1.2-2.185.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Boot a qcow2 image.

/usr/libexec/qemu-kvm -M rhel6.1.0 -cpu cpu64-rhel6,+x2apic -enable-kvm -m 4096 -smp 1 -name RHEL6.2-64 -uuid 075527b4-a514-4c58-aad3-84edfe54bb84 -monitor stdio -rtc base=localtime -boot c -device virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0,addr=0x3 -drive file=/home/RHEL6.2-64.qcow2,if=none,id=virtio-drive-0,format=qcow2,cache=none,werror=stop,rerror=stop -device ide-drive,bus=ide.0,drive=virtio-drive-0,id=virtio0 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:1a:4a:16:28:12,bus=pci.0,addr=0x5 -chardev socket,id=charchannel0,path=/tmp/foo,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev spicevmc,id=charchannel1,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=com.redhat.spice.0 -usb -spice port=5930,disable-ticketing -k en-us -vga qxl -global qxl-vga.vram_size=67108864 -device virtio-balloon-pci,bus=pci.0,id=balloon0

2.(qemu) info snapshots 
(qemu) savevm sn1

3.After step 2 finished, load sn1.
(qemu) loadvm sn1

  
Actual results:
Guest image got corrupted, please check the error message in bug description.

Expected results:
No corruption for guest image.

Additional info:
Test on qemu-kvm-0.12.1.2-2.178.el6.x86_64, this issue exists as well.

Comment 4 Suqin Huang 2012-07-30 02:30:41 UTC
Hi kevin,
Can we close this bug, seems internal snapshot is not supported.

Suqin

Comment 5 Kevin Wolf 2012-07-30 07:41:17 UTC
Let's leave it open with low priority.

Comment 7 Kevin Wolf 2013-04-17 14:13:33 UTC
I tried to reproduce this, but I can neither on current RHEL 6, nor in the -185
build. Is this really 100% reproducible for you?

Comment 8 Ademar Reis 2013-05-17 15:39:07 UTC
Internal snapshot is not supported and Kevin couldn't reproduce it. So I'm closing it.


Note You need to log in before you can comment on or make changes to this bug.