Bug 736247 - When providing unexisting user, no proper message is shown
Summary: When providing unexisting user, no proper message is shown
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: Garik Khachikyan
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-09-07 07:00 UTC by Ivan Necas
Modified: 2015-01-04 21:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:55:59 UTC


Attachments (Terms of Use)

Description Ivan Necas 2011-09-07 07:00:46 UTC
How reproducible:


Steps to Reproduce:
1. katello --u non-existing-user -p password  org list

  
Actual results:
error: operation failed:

Expected results:
error: There is no user 'non-existing-user' in the system (or something like this)

Comment 1 Ivan Necas 2011-09-19 09:48:01 UTC
Fixed in commit 065caa08c48c44fcb6a446328f9eededfecd13d9

Comment 2 Garik Khachikyan 2011-09-23 14:10:11 UTC
# VERIFIED

fixed now. when wrong credentials are provided, there is messaging:
---
Invalid credentials or unable to authenticate
$? = 145
---

Comment 5 Mike McCune 2013-08-16 17:58:53 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.