Bug 736249 - ups service report failure if started via systemd in netclient mode
Summary: ups service report failure if started via systemd in netclient mode
Keywords:
Status: CLOSED DUPLICATE of bug 732151
Alias: None
Product: Fedora
Classification: Fedora
Component: nut
Version: 14
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Michal Hlavinka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-07 07:10 UTC by Sergey Kryzhny
Modified: 2011-09-09 08:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-09 08:55:27 UTC


Attachments (Terms of Use)

Description Sergey Kryzhny 2011-09-07 07:10:25 UTC
Description of problem:
After configure nut to run in netclient mode, any attempt to start ups service in systemd-enabled OS result in reporting that service failed.


Version-Release number of selected component (if applicable):
nut-client.x86_64                   2.6.1-1.fc14                      @updates

How reproducible:
Always

Steps to Reproduce:
1. configure nut to use netclient mode. set SERVER=no in /etc/sysconfig/ups 
2. start ups service: sudo /etc/init.d/ups start
3.
  
Actual results:
systemd report service failure.

Expected results:
Running service with "active" status.

Additional info:
It fixed by adding RETVAL=0 in line 40 of /etc/init.d/ups
Script use uninitialized value in case of netclient mode.
Same problem must be also in Upstart-based systems, but without reporting error to logs.
Fedora15 has same bug.

Comment 1 Michal Hlavinka 2011-09-09 08:55:27 UTC
this is already fixed. Package is in updates-testing repository right now.

*** This bug has been marked as a duplicate of bug 732151 ***


Note You need to log in before you can comment on or make changes to this bug.