Bug 736264 - snmpd: error finding row index in _ifXTable_container_row_restore
Summary: snmpd: error finding row index in _ifXTable_container_row_restore
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: net-snmp
Version: 5.7
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jan Safranek
QA Contact: Dalibor Pospíšil
URL:
Whiteboard: SA233413396
Depends On:
Blocks: 788954
TreeView+ depends on / blocked
 
Reported: 2011-09-07 08:27 UTC by Josef Möllers
Modified: 2018-11-26 17:24 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Prior to this update, snmpd reported 'snmpd: error finding row index in _ifXTable_container_row_restore' in system log when the snmpd was started and did not find a network interface, which was present during last snmpd shutdown. This happened usually on systems, which dynamically create and remove network interfaces on demand, like virtual hosts or PPP servers. In this update, this message was removed and it should not appear in system log.
Clone Of:
: 788954 (view as bug list)
Environment:
Last Closed: 2012-02-21 06:32:17 UTC


Attachments (Terms of Use)
Sosreport (1.84 MB, application/x-bzip)
2011-09-07 08:27 UTC, Josef Möllers
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0165 normal SHIPPED_LIVE net-snmp bug fix update 2012-02-20 15:06:44 UTC
Red Hat Knowledge Base (Legacy) 45173 None None None Never

Description Josef Möllers 2011-09-07 08:27:22 UTC
Created attachment 521816 [details]
Sosreport

Description of problem:
Under load, the error message "snmpd: error finding row index in _ifXTable_container_row_restore" appears in /var/log/messages.

Version-Release number of selected component (if applicable):
net-snmp-5.3.2.2-14.el5.x86_64

How reproducible:
Varying: on the QA system: reproducable, on our lab system: not reproducable. 

Steps to Reproduce:
1) Install RHEL5_U7 on TX150S7_4 (x64 bits architecture or x64_XEN) or TX200S6-4(x64 bits architecture or x64_XEN) or RX300S6-1(x64_XEN)
2) Run automated tests(like memtest, CPU_stress, CCTEST,reboot tests)
3) Verify /var/logs
  
Actual results:
Error appears in /var/log/messages.

Expected results:
No errors should occur after automated tests are finished.

Additional info:
A similar bug was reported in 2007 against fc6 (net-snmp 5.3.1): Bug 221911: snmpd errors under xen.

Comment 1 Jan Safranek 2011-09-12 07:14:59 UTC
The message is completely harmless. snmpd stores table of network interfaces on shutdown and tries to restore it on next start. The message is shown if the set of interfaces is different on shutdown and the next start, typically when an interface is removed.

I'll try to lower severity of the message so it's shown only when debug logs are explicitly requested.

Comment 3 Jan Safranek 2011-10-27 10:05:42 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Prior to this update, snmpd reported 'snmpd: error finding row index in _ifXTable_container_row_restore' in system log when the snmpd was started and did not find a network interface, which was present during last snmpd shutdown. This happened usually on systems, which dynamically create and remove network interfaces on demand, like virtual hosts or PPP servers. In this update, severity of this message is lowered and it should not appear in system log.

Comment 5 Jan Safranek 2011-11-22 15:55:03 UTC
(In reply to comment #1)
> I'll try to lower severity of the message so it's shown only when debug logs
> are explicitly requested.

I removed the message completely, it's quite useless. Sorry for the confusion.

Comment 6 Jan Safranek 2011-11-22 15:55:04 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Prior to this update, snmpd reported 'snmpd: error finding row index in _ifXTable_container_row_restore' in system log when the snmpd was started and did not find a network interface, which was present during last snmpd shutdown. This happened usually on systems, which dynamically create and remove network interfaces on demand, like virtual hosts or PPP servers. In this update, severity of this message is lowered and it should not appear in system log.+Prior to this update, snmpd reported 'snmpd: error finding row index in _ifXTable_container_row_restore' in system log when the snmpd was started and did not find a network interface, which was present during last snmpd shutdown. This happened usually on systems, which dynamically create and remove network interfaces on demand, like virtual hosts or PPP servers. In this update, this message was removed and it should not appear in system log.

Comment 10 errata-xmlrpc 2012-02-21 06:32:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0165.html


Note You need to log in before you can comment on or make changes to this bug.