Bug 736300 - SELinux is preventing smbcontrol from read/write operation on /dev/console
Summary: SELinux is preventing smbcontrol from read/write operation on /dev/console
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy
Version: 6.2
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Miroslav Grepl
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-07 10:35 UTC by Milos Malik
Modified: 2012-09-26 14:00 UTC (History)
2 users (show)

Fixed In Version: selinux-policy-3.7.19-110.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 10:18:22 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1511 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2011-12-06 00:39:17 UTC

Description Milos Malik 2011-09-07 10:35:16 UTC
Description of problem:


Version-Release number of selected component (if applicable):
selinux-policy-3.7.19-109.el6.noarch
selinux-policy-targeted-3.7.19-109.el6.noarch
samba-3.5.10-99.el6.i686
samba-common-3.5.10-99.el6.i686

How reproducible:
always

Steps to Reproduce:
1. get a fresh RHEL-6.2 machine
2. log in as root via console
3. run following automated test:
/CoreOS/selinux-policy/Regression/bz429726-smbd-cannot-change-unix-passwords
  
Actual results:
----
time->Wed Sep  7 05:26:26 2011
type=SYSCALL msg=audit(1315387586.565:236350): arch=40000003 syscall=11 success=yes exit=0 a0=8a9a7d0 a1=8a969b8 a2=8a27660 a3=8a969b8 items=0 ppid=12849 pid=14983 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="smbcontrol" exe="/usr/bin/smbcontrol" subj=unconfined_u:unconfined_r:smbcontrol_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1315387586.565:236350): avc:  denied  { read write } for  pid=14983 comm="smbcontrol" path="/dev/console" dev=devtmpfs ino=5261 scontext=unconfined_u:unconfined_r:smbcontrol_t:s0-s0:c0.c1023 tcontext=system_u:object_r:console_device_t:s0 tclass=chr_file
----

Expected results:
* no AVCs

Comment 1 Miroslav Grepl 2011-09-07 12:34:04 UTC
We have this in RHEL5

term_use_console(smbcontrol_t)

Comment 2 Miroslav Grepl 2011-09-08 14:30:17 UTC
Fixed in selinux-policy-3.7.19-110.el6

Comment 5 errata-xmlrpc 2011-12-06 10:18:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1511.html


Note You need to log in before you can comment on or make changes to this bug.