Bug 736345 - rpmbuild -a fails
Summary: rpmbuild -a fails
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: hekafs
Version: 16
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-07 13:14 UTC by Kaleb KEITHLEY
Modified: 2011-09-09 15:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-09 15:25:00 UTC


Attachments (Terms of Use)

Description Kaleb KEITHLEY 2011-09-07 13:14:55 UTC
Description of problem:

Robert Brown(email?) reports on hekafs.org blog that rpmbuild -a hekafs.spec fails

Version-Release number of selected component (if applicable):

0.7-10

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:Can you clarify how this applies to the Rawhide package of HekaFS? Specifically this:

http://mirrors.kernel.org/fedora/development/rawhide/source/SRPMS/hekafs-0.7-10.fc17.src.rpm

Let’s say we already rolled glusterfs 3.2.3 and have it installed. Typically I would just rpmbuild -a hekafs.spec, but I wind up with this:

config.status: executing libtool commands
+ /usr/bin/make
/usr/bin/make all-recursive
make[1]: Entering directory `/root/rpmbuild/BUILD/hekafs-0.7′
Making all in crypt
make[2]: Entering directory `/root/rpmbuild/BUILD/hekafs-0.7/crypt’
/bin/sh ../libtool –tag=CC –mode=compile gcc -DHAVE_CONFIG_H -I. -I.. -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -Wall -DGF_LINUX_HOST_OS -iquote/usr/include/glusterfs -iquote/usr/include/glusterfs/rpc -iquote/usr/include/glusterfs/server -shared -nostartfiles -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector –param=ssp-buffer-size=4 -m64 -mtune=generic -MT crypt.lo -MD -MP -MF .deps/crypt.Tpo -c -o crypt.lo crypt.c
mv -f .deps/crypt.Tpo .deps/crypt.Plo
mv: cannot stat `.deps/crypt.Tpo’: No such file or directory
make[2]: *** [crypt.lo] Error 1
make[2]: Leaving directory `/root/rpmbuild/BUILD/hekafs-0.7/crypt’
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/rpmbuild/BUILD/hekafs-0.7′
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.7WgtUh (%build)

Comment 1 Jeff Darcy 2011-09-07 13:29:36 UTC
My preliminary investigation showed that "rpmbuild -a" isn't even a valid option in current versions, and that the problem was only reproducible by using "rpmbuild --nodeps" to attempt a build without prerequisites (specifically glusterfs-devel) being satisfied.  Unless more information is provided, I'd be inclined to call this pilot error.

Comment 2 Kaleb KEITHLEY 2011-09-09 15:25:00 UTC
Closing. I can't tell what -a was supposed to do, it's not in the rpmbuild man page any version of rpm from 4.4.x to current (or rpm5). I am mildly interested in knowing what distro has an rpmbuild with -a.

As Jeff points out, this can be exactly reproduced by not having glusterfs-devel installed and building with `rpmbuild -bb --nodeps SPECS/hekafs.spec` and is an operator error.

Installing glusterfs-devel should result in hekafs building successfully. We can reopen this bz if we get more information to the contrary.


Note You need to log in before you can comment on or make changes to this bug.