Bug 736392 - Starting Failed Messages
Summary: Starting Failed Messages
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 15
Hardware: i686
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-07 15:11 UTC by Cielito
Modified: 2012-01-25 16:18 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-25 16:18:16 UTC


Attachments (Terms of Use)
Network situation and mount situation (70.42 KB, text/plain)
2011-09-07 15:12 UTC, Cielito
no flags Details

Description Cielito 2011-09-07 15:11:42 UTC
Description of problem:
Mount of network windows directory does not occur.

Version-Release number of selected component (if applicable):
$ uname -a
Linux PC-Linux 2.6.40.4-5.fc15.i686 #1 SMP Tue Aug 30 14:54:41 UTC 2011 i686 i686 i386 GNU/Linux
$ rpm -qa|grep cifs
cifs-utils-5.0-2.fc15.i686


How reproducible:
It's reproducible trying to automatically mount a directory to exist on a windows server. In my case the server is windows server 2003 R2. By adding the appropriate line in /etc/fstab (as shown in the attachments) is not the mount. At boot time you have error messages and you can not enable this option. View attachments.


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Circumvented the problem by writing in /etc/rc.local the line "systemctl start mnt-server.mount". Mount the partition but it still happens at boot errors.

Expected results:


Additional info:
These are the posts before adding the line in / etc / rc.local
Starting /mnt/server [1;31mfailed[0m, see 'systemctl status mnt-server.mount' for details.

[root@PC-Linux ~]# systemctl status mnt-server.mount
mnt-server.mount - /mnt/server
	  Loaded: loaded
	  Active: failed since Tue, 30 Aug 2011 16:22:32 +0200; 13min ago
	   Where: /mnt/server
	    What: /192.168.2.250/dati
	 Process: 812 ExecMount=/bin/mount /mnt/server (code=exited, status=32)
	  CGroup: name=systemd:/system/mnt-server.mount
[root@PC-Linux ~]#

These are the messages after adding the line in / etc / rc.local
[root@PC-Linux ~]# systemctl status mnt-server.mount
mnt-server.mount - /mnt/server
	  Loaded: loaded
	  Active: active (mounted) since Wed, 07 Sep 2011 12:50:54 +0200; 4h 17min ago
	   Where: /mnt/server
	    What: //192.168.2.250/dati
	  CGroup: name=systemd:/system/mnt-server.mount
[root@PC-Linux ~]#

Comment 1 Cielito 2011-09-07 15:12:39 UTC
Created attachment 521907 [details]
Network situation and mount situation

Comment 2 Lennart Poettering 2011-09-19 23:16:40 UTC
do you use networkmanager? Normally we don't delay boot for the network. if you want such a behaviour you have to manually enable that via "systemctl enable NetworkManager-wait.service".

Comment 3 Cielito 2011-09-20 07:11:51 UTC
I think that the network connections you should start automatically. Manually enabling enable "systemctl NetworkManager-wait.service" allows to start automatically the next time?  Using Network instead Network Manager, the situation would change?

Comment 4 Lennart Poettering 2011-09-21 18:10:26 UTC
Not sure I grok your questions.

Does "sc e NM-w.s" make things work for you?

Comment 5 Cielito 2011-09-22 07:29:46 UTC
[root@PC-Linux ~]# systemctl enable NetworkManager-wait.service
Couldn't find NetworkManager-wait.service.
[root@PC-Linux ~]# 

I think is not working.

Comment 6 Michal Schmidt 2011-09-22 22:11:14 UTC
It's NetworkManager-wait-online.service

Comment 7 Cielito 2011-09-23 14:08:14 UTC
All right. This works. It would be good to have it already running when you establish a network connection automatically.

Comment 8 Fedora Admin XMLRPC Client 2011-10-20 16:29:06 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.


Note You need to log in before you can comment on or make changes to this bug.