Bug 736405 - [abrt] evolution-data-server-2.32.2-1.fc14: g_atomic_int_get: Process /usr/libexec/e-addressbook-factory was killed by signal 11 (SIGSEGV)
Summary: [abrt] evolution-data-server-2.32.2-1.fc14: g_atomic_int_get: Process /usr/li...
Keywords:
Status: CLOSED DUPLICATE of bug 693225
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server
Version: 14
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:82968145754d1c394ef0dab2047...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-07 15:40 UTC by Andrew Kornak
Modified: 2011-09-08 09:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-08 09:05:43 UTC


Attachments (Terms of Use)
File: backtrace (15.48 KB, text/plain)
2011-09-07 15:40 UTC, Andrew Kornak
no flags Details

Description Andrew Kornak 2011-09-07 15:40:29 UTC
abrt version: 1.1.18
architecture: i686
Attached file: backtrace, 15852 bytes
cmdline: /usr/libexec/e-addressbook-factory
component: evolution-data-server
Attached file: coredump, 27545600 bytes
crash_function: g_atomic_int_get
executable: /usr/libexec/e-addressbook-factory
kernel: 2.6.35.14-95.fc14.i686
package: evolution-data-server-2.32.2-1.fc14
rating: 4
reason: Process /usr/libexec/e-addressbook-factory was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1315409824
uid: 500

How to reproduce
-----
1. clicked on contacts in evolution
2. address book crashed
3.

Comment 1 Andrew Kornak 2011-09-07 15:40:32 UTC
Created attachment 521926 [details]
File: backtrace

Comment 2 Milan Crha 2011-09-08 09:05:43 UTC
Thanks for a bug report. Based on the backtrace I suppose this crashed because one of your contact doesn't contain only valid UTF8 letters, thus the GVariant crashes on it. There was done a fix for this, which is included in evolution-data-server 3.0.0. I'm marking this as a duplicate of bug #693225.

*** This bug has been marked as a duplicate of bug 693225 ***


Note You need to log in before you can comment on or make changes to this bug.