Bug 73641 - undefined variables in g2c.h
undefined variables in g2c.h
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
http://gcc.gnu.org/ml/gcc-bugs/2002-0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-07 13:33 EDT by Need Real Name
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 00:05:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-09-07 13:33:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux)

Description of problem:
g2c.h contains undefined vars that break C++ interface

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
 

Additional info:

The problem is well docmented at:
http://gcc.gnu.org/ml/gcc-bugs/2002-04/msg00525.html

For what it's worth, here is the diff/patch for my i686:
21,22c21,22
< typedef __g77_integer integer;
< typedef __g77_uinteger uinteger;
---
> typedef long int integer;
> typedef unsigned long int uinteger;
29c29
< typedef __g77_integer logical;
---
> typedef long int logical;
33,34c33,34
< typedef __g77_longint longint;       /* system-dependent */
< typedef __g77_ulongint ulongint;     /* system-dependent */
---
> typedef long long int longint;       /* system-dependent */
> typedef unsigned long long int ulongint;      /* system-dependent */
55,57c55,57
< typedef __g77_integer flag;
< typedef __g77_integer ftnlen;
< typedef __g77_integer ftnint;
---
> typedef long int flag;
> typedef long int ftnlen;
> typedef long int ftnint;
Comment 1 Richard Henderson 2004-10-03 00:05:24 EDT
Fixed in gcc 3.2.

Note You need to log in before you can comment on or make changes to this bug.