Bug 736431 - parent tombstone entry could be reaped even if its child tombstone entries still exist
Summary: parent tombstone entry could be reaped even if its child tombstone entries st...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: 389
Classification: Retired
Component: Replication - General
Version: 1.2.9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Noriko Hosoi
QA Contact: Viktor Ashirov
URL:
Whiteboard:
: 737811 767024 (view as bug list)
Depends On:
Blocks: 690319 781516
TreeView+ depends on / blocked
 
Reported: 2011-09-07 16:48 UTC by Noriko Hosoi
Modified: 2015-12-07 17:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 781516 (view as bug list)
Environment:
Last Closed: 2015-12-07 17:09:57 UTC


Attachments (Terms of Use)

Description Noriko Hosoi 2011-09-07 16:48:31 UTC
Description of problem:
Anthony Messina 2011-09-05 23:18:59 EDT

Using 389-ds-base-1.2.9.9-1.fc15.x86_64

I see the following when backing up the db:
[05/Sep/2011:03:30:11 -0500] ldif2dbm - _get_and_add_parent_rdns: Failed to
position at ID 29
[05/Sep/2011:03:30:11 -0500] - ldbm2ldif: Failed to get dn of ID 29
[05/Sep/2011:03:30:11 -0500] - export userRoot: Processed 359 entries (100%).
[05/Sep/2011:03:30:11 -0500] - All database threads now stopped
[05/Sep/2011:03:30:11 -0500] - export NetscapeRoot: Processed 109 entries
(100%).
[05/Sep/2011:03:30:11 -0500] - All database threads now stopped
        389-Directory/1.2.9.9 B2011.244.2041


And the following later on:
[05/Sep/2011:14:11:59 -0500] _entry_set_tombstone_rdn - Failed to convert DN
uid=aae5b81917538f54cabd7e7d290db106 to RDN
[05/Sep/2011:14:11:59 -0500] id2entry - str2entry returned NULL for id 30,
string="rdn"
[05/Sep/2011:22:13:08 -0500] _entry_set_tombstone_rdn - Failed to convert DN
uid=aae5b81917538f54cabd7e7d290db106 to RDN
[05/Sep/2011:22:13:08 -0500] id2entry - str2entry returned NULL for id 30,
string="rdn"
[05/Sep/2011:22:13:45 -0500] _entry_set_tombstone_rdn - Failed to convert DN
uid=aae5b81917538f54cabd7e7d290db106 to RDN
[05/Sep/2011:22:13:45 -0500] id2entry - str2entry returned NULL for id 30,
string="rdn"

[reply] [-]
Private
Comment 5 Noriko Hosoi 2011-09-06 12:49:13 EDT

Hi Anthony,
Could it be possible to post the output from these command lines?
dbscan -f /path/to/db/userRoot/id2entry.db4 -K 29
dbscan -f /path/to/db/userRoot/id2entry.db4 -K 30
Thanks,
--noriko

[reply] [-]
Private
Comment 6 Anthony Messina 2011-09-06 13:36:10 EDT

Sure, they both come from entries that were deleted.  The first one is gone
from the DB.  The second doesn't show up during an ldapsearch, but is avaiable
via the command below:

# dbscan -f /var/lib/dirsrv/slapd-ds/db/userRoot/id2entry.db4 -K 29
Can't set cursor to returned item: DB_NOTFOUND: No matching key/data pair found


# dbscan -f /var/lib/dirsrv/slapd-ds/db/userRoot/id2entry.db4 -K 30
id 30
        rdn:
nsuniqueid=de6aa638-282011df-a269e3fe-897a001a,uid=aae5b81917538f54cabd7e
         7d290db106
        nsUniqueId: de6aa638-282011df-a269e3fe-897a001a

<entry snipped>

[reply] [-]
Private
Comment 7 Noriko Hosoi 2011-09-06 18:53:35 EDT

Thanks, Anthony.  I tried to duplicate your problem, but so far no luck.

It looks you have some deleted entries which are turned to tombstone entries
once (entry 29 and 30).  Then, some of them are reaped (entry 29).  I wonder if
entry 29 could have been a parent of entry 30?  (I don't think a parent can be
deleted prior to its child, so I'm not sure how it could happen if it is the
case...)  But this could be just my imagination.  I guess we need more detailed
data to investigate the problem.

Do you happen to have steps to reproduce the problem?

[reply] [-]
Private
Comment 8 Anthony Messina 2011-09-07 05:38:35 EDT

(In reply to comment #7)
> Thanks, Anthony.  I tried to duplicate your problem, but so far no luck.
> 
> It looks you have some deleted entries which are turned to tombstone entries
> once (entry 29 and 30).  Then, some of them are reaped (entry 29).  I wonder if
> entry 29 could have been a parent of entry 30?  (I don't think a parent can be
> deleted prior to its child, so I'm not sure how it could happen if it is the
> case...)  But this could be just my imagination.  I guess we need more detailed
> data to investigate the problem.
> 
> Do you happen to have steps to reproduce the problem?

I believe you are right when you say that 29 was a parent of 30.  In fact, the
30 entry I have was deleted at the same time as its parent (29) via the
389-console.

It would have had the following structure:
uid=aae5b81917538f54cabd7e7d290db106,cn=user1,ou=personal,ou=contacts,ou=messinet.com,ou=eGW,dc=messinet,dc=com

and cn=user1,ou=personal,ou=contacts,ou=messinet.com,ou=eGW,dc=messinet,dc=com
was the entry I deleted via 389-console.

Comment 3 Noriko Hosoi 2011-12-21 00:11:30 UTC
*** Bug 737811 has been marked as a duplicate of this bug. ***

Comment 4 Noriko Hosoi 2012-01-03 22:27:36 UTC
[trac] https://fedorahosted.org/389/ticket/2

Comment 5 Martin Kosek 2012-01-04 13:21:50 UTC
Upstream ticket:
https://fedorahosted.org/389/ticket/33

Comment 6 Noriko Hosoi 2012-01-05 20:34:10 UTC
Note: https://fedorahosted.org/389/ticket/33 is closed as a duplicate of ticket 2.

Comment 7 Rich Megginson 2012-01-13 16:19:21 UTC
*** Bug 767024 has been marked as a duplicate of this bug. ***

Comment 8 Amita Sharma 2012-04-25 08:54:41 UTC
mmrepl mmraccept startup 	100% (2/2) 	  	 
mmrepl mmraccept run 	100% (22/22) 	  	 
mmrepl mmraccept cleanup 	100% (1/1)

Hence VERIFIED.


Note You need to log in before you can comment on or make changes to this bug.