Bug 736434 - Raeon HD 4670 Refresh Problems
Summary: Raeon HD 4670 Refresh Problems
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 16
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-07 17:01 UTC by Barry Fishman
Modified: 2018-04-11 09:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-17 01:37:03 UTC


Attachments (Terms of Use)
lspci results (2.44 KB, text/plain)
2011-09-07 17:01 UTC, Barry Fishman
no flags Details
Xorg.0.log file (84.50 KB, text/plain)
2011-09-08 14:32 UTC, Barry Fishman
no flags Details
dmesg output (123.74 KB, text/plain)
2011-09-08 14:33 UTC, Barry Fishman
no flags Details
/var/log/messages contents (2.55 MB, text/plain)
2011-09-08 14:35 UTC, Barry Fishman
no flags Details

Description Barry Fishman 2011-09-07 17:01:21 UTC
Created attachment 521947 [details]
lspci results

Description of problem:
When running xzgv on multiple images, rather than displaying the next image, sometimes ony a small rectangle of the image is displayed.

In terminal windows (especially urxvt) only a small part of the window is updated when a key is pressed or output is to be displayed.

Version-Release number of selected component (if applicable):
xzgv 0.9.1


How reproducible:

Always

Steps to Reproduce:
1. Login
2. From a terminal run xzgv on a list of files
  
Actual results:

As described

Expected results:

The full window should be refreshed.

Additional info:

When running the first group of testday tests everything worked except the fastuserswitch test which would not let me login as another user, but
kept going back to the current session.

The suspend test worked, but I needed to restart the network from the network manager.

Comment 1 Matěj Cepl 2011-09-07 20:20:14 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log*; check with grep Backtrace /var/log/Xorg* which logs might be the most interesting ones, send us at least Xorg.0.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 Barry Fishman 2011-09-08 14:32:41 UTC
Created attachment 522136 [details]
Xorg.0.log file

Comment 3 Barry Fishman 2011-09-08 14:33:24 UTC
Created attachment 522137 [details]
dmesg output

Comment 4 Barry Fishman 2011-09-08 14:35:54 UTC
Created attachment 522138 [details]
/var/log/messages contents

Comment 5 Barry Fishman 2011-09-08 14:44:45 UTC
The new attachments are the results after rebooting with the drm.debug=0x04 set,
and running xzgv in fullscreen which had the refresh problems.

There did not seem to be a Backtrace in the Xorg logs.

There was no /etc/X11/xorg.conf, but there was a xorg.conf.d/000-system-setup-keyboard.conf containing just:

# This file is autogenerated by system-setup-keyboard. Any 
# modifications will be lost.

Section "InputClass"
	Identifier	"system-setup-keyboard"
	MatchIsKeyboard	"on"
	Option		"XkbModel"	"pc105+inet"
	Option		"XkbLayout"	"us"
#	Option		"XkbVariant"	"(null)"
	Option		"XkbOptions"	"terminate:ctrl_alt_bksp,"
EndSection

Comment 6 Barry Fishman 2011-09-17 01:37:03 UTC
As of today's updates 2011-09-16, the problem seems to have been
fixed.


Note You need to log in before you can comment on or make changes to this bug.