Bug 736468 - garbage printed on get_ip_address("badNicValue")
Summary: garbage printed on get_ip_address("badNicValue")
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: matahari
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Russell Bryant
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks: 743047
TreeView+ depends on / blocked
 
Reported: 2011-09-07 18:58 UTC by Dave Johnson
Modified: 2011-12-06 11:42 UTC (History)
1 user (show)

Fixed In Version: matahari-0.4.4-1.el6
Doc Type: Bug Fix
Doc Text:
No description required.
Clone Of:
Environment:
Last Closed: 2011-12-06 11:42:57 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1569 normal SHIPPED_LIVE matahari bug fix and enhancement update 2011-12-06 00:39:06 UTC

Description Dave Johnson 2011-09-07 18:58:30 UTC
Description of problem:
====================================
Using the network agent, call get_ip_address with a non-existent nic and see that the response contains garbage in the ip field.

Version-Release number of selected component (if applicable):
========================================================================
v0.4.3-1

How reproducible:
====================================
100%

Steps to Reproduce:
====================================
1.  call  get_ip_address("badNicValue")

Comment 1 Dave Johnson 2011-09-07 18:59:08 UTC
FYI, this is not the case get_mac_address()

Comment 6 Dave Johnson 2011-09-09 18:29:47 UTC
good 2 go in v0.4.4-2

Comment 7 Russell Bryant 2011-11-16 22:15:19 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description required.

Comment 8 errata-xmlrpc 2011-12-06 11:42:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1569.html


Note You need to log in before you can comment on or make changes to this bug.