Bug 736478 - monitors get misconfigured every time I reboot
Summary: monitors get misconfigured every time I reboot
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon
Version: 15
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-07 19:16 UTC by Renich Bon Ciric
Modified: 2012-08-07 15:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-07 15:26:53 UTC


Attachments (Terms of Use)

Description Renich Bon Ciric 2011-09-07 19:16:56 UTC
Description of problem:
The monitors of the Ghia mini-pc get misconfigured every time. The result is: you don't see the login screen and, the main monitor, get's detected as the second one.

Check this out:
$ xrandr -q
Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 4096 x 4096
LVDS1 connected (normal left inverted right x axis y axis)
   1024x768       60.0 +
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 473mm x 296mm
   1680x1050      60.0*+
   1600x1000      60.0  
   1280x1024      75.0  
   1440x900       59.9  
   1280x960       60.0  
   1152x864       75.0  
   1152x720       60.0  
   1024x768       75.1     60.0  
   832x624        74.6  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1 

The thing is that LVDS1 does not have a physical connection... it doesn't exist.

My guess is that the MB is used for netbooks too. Anyway, I solved this by creating the /etc/gnome-settings-daemon/xrandr/monitors.xml 

with the following contents:
<monitors version="1">
  <configuration>
      <clone>no</clone>
      <output name="default">
          <vendor>???</vendor>
          <product>0x0000</product>
          <serial>0x00000000</serial>
          <width>1024</width>
          <height>768</height>
          <rate>0</rate>
          <x>0</x>
          <y>0</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>yes</primary>
      </output>
  </configuration>
  <configuration>
      <clone>no</clone>
      <output name="LVDS1">
          <vendor>???</vendor>
          <product>0x0000</product>
          <serial>0x00000000</serial>
          <primary>no</primary>
      </output>
      <output name="VGA1">
          <vendor>HWP</vendor>
          <product>0x26a8</product>
          <serial>0x01010101</serial>
          <width>1680</width>
          <height>1050</height>
          <rate>60</rate>
          <x>0</x>
          <y>0</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>yes</primary>
      </output>
  </configuration>
</monitors>

As much as I played with gsettings, I couldn't make the changes. Also, while playing with xrandr, I found that:

DISPLAY=:0 xrandr --output LVDS1 --off --output VGA1 --primary

resolved the issue but did not persist. So, the above solution worked.

Anyway, I hope this gets worked out. I've seen enough posts about this; with inconsistent solutions.

Comment 1 Renich Bon Ciric 2011-11-29 17:49:21 UTC
this keeps happening...

Comment 2 Fedora End Of Life 2012-08-07 15:26:55 UTC
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.