Bug 736490 - Cannot push image to EC2 east or west Error:InvalidGroup.InUse
Summary: Cannot push image to EC2 east or west Error:InvalidGroup.InUse
Keywords:
Status: CLOSED DUPLICATE of bug 726203
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: imagefactory
Version: 1.0.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
Assignee: Ian McLeod
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-07 20:02 UTC by Douglas Woods
Modified: 2012-01-26 12:18 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-07 16:01:35 UTC


Attachments (Terms of Use)
template file for build image (343 bytes, application/octet-stream)
2011-09-07 20:02 UTC, Douglas Woods
no flags Details
Build image script for template.tpl (56 bytes, application/x-shellscript)
2011-09-07 20:03 UTC, Douglas Woods
no flags Details
push image script to EC2 east (172 bytes, application/x-shellscript)
2011-09-07 20:04 UTC, Douglas Woods
no flags Details

Description Douglas Woods 2011-09-07 20:02:53 UTC
Created attachment 521994 [details]
template file for build image

Description of problem:
When initiating this image push to either East or West EC2. Could not determine if this is the same issue as Bug 726203.Attached 
"aeolus-image push --provider ec2-us-east-1 --id 89d7b0a8-86fd-43b8-b8c9-a972d73b8fb8". The AMI Image appears to have been pushed, but the log shows
EC2ResponseError: EC2ResponseError: 400 Bad Request
<?xml version="1.0" encoding="UTF-8"?>
<Response><Errors><Error><Code>InvalidGroup.InUse</Code><Message>There are active instances using security group 'imagefactory-a13aee23-96cc-48ed-ba27-9aefee8e92e6'</Message></Error></Errors><RequestID>d9ac4dc0-7da5-403e-9eb4-62dff9f3cb72</RequestID></Response>


Version-Release number of selected component (if applicable):


How reproducible:
push an image to either East or West EC2

Steps to Reproduce:
1.aeolus-image push --provider ec2-us-east-1 --id 89d7b0a8-86fd-43b8-b8c9-a972d73b8fb8
2.
3.
  
Actual results:
2011-09-07 11:38:28,085 DEBUG imagefactory.builders.BaseBuilder.FedoraBuilder pid(2531) Message: Register output: IMAGE	ami-5709ca3e

2011-09-07 11:38:28,087 DEBUG imagefactory.builders.BaseBuilder.FedoraBuilder pid(2531) Message: Extracted AMI ID: ami-5709ca3e 
2011-09-07 11:38:28,091 INFO imagefactory.ImageWarehouse.ImageWarehouse pid(2531) Message: Creating a bucket returned status 500.
2011-09-07 11:38:28,119 DEBUG imagefactory.ImageWarehouse.ImageWarehouse pid(2531) Message: Setting metadata ({'object_type': 'icicle', 'uuid': '0df80166-ff5f-4f38-ae64-f63a2c0547e3'}) for http://localhost:9090/icicles/0df80166-ff5f-4f38-ae64-f63a2c0547e3
2011-09-07 11:38:28,205 INFO imagefactory.ImageWarehouse.ImageWarehouse pid(2531) Message: Creating a bucket returned status 500.
2011-09-07 11:38:28,210 DEBUG imagefactory.ImageWarehouse.ImageWarehouse pid(2531) Message: Setting metadata ({'target_image': 'd50bd013-44e5-435f-b887-aec66245f2ec', 'uuid': 'a13aee23-96cc-48ed-ba27-9aefee8e92e6', 'icicle': '0df80166-ff5f-4f38-ae64-f63a2c0547e3', 'target_identifier': 'ami-5709ca3e', 'object_type': 'provider_image', 'provider': 'ec2-us-east-1'}) for http://localhost:9090/provider_images/a13aee23-96cc-48ed-ba27-9aefee8e92e6
2011-09-07 11:38:28,462 DEBUG imagefactory.builders.BaseBuilder.FedoraBuilder pid(2531) Message: Stopping EC2 instance and deleting temp security group
2011-09-07 11:38:30,272 ERROR boto pid(2531) Message: 400 Bad Request
2011-09-07 11:38:30,273 ERROR boto pid(2531) Message: <?xml version="1.0" encoding="UTF-8"?>
<Response><Errors><Error><Code>InvalidGroup.InUse</Code><Message>There are active instances using security group 'imagefactory-a13aee23-96cc-48ed-ba27-9aefee8e92e6'</Message></Error></Errors><RequestID>d9ac4dc0-7da5-403e-9eb4-62dff9f3cb72</RequestID></Response>
2011-09-07 11:38:30,274 DEBUG imagefactory.builders.BaseBuilder.FedoraBuilder pid(2531) Message: Exception caught in ImageFactory
2011-09-07 11:38:30,277 DEBUG imagefactory.builders.BaseBuilder.FedoraBuilder pid(2531) Message: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/imagefactory/builders/FedoraBuilder.py", line 499, in push_image
    self.push_image_snapshot(target_image_id, provider, credentials)
  File "/usr/lib/python2.6/site-packages/imagefactory/builders/FedoraBuilder.py", line 511, in push_image_snapshot
    self.push_image_snapshot_ec2(target_image_id, provider, credentials)
  File "/usr/lib/python2.6/site-packages/imagefactory/builders/FedoraBuilder.py", line 856, in push_image_snapshot_ec2
    factory_security_group.delete()
  File "/usr/lib/python2.6/site-packages/boto/ec2/securitygroup.py", line 72, in delete
    return self.connection.delete_security_group(self.name)
  File "/usr/lib/python2.6/site-packages/boto/ec2/connection.py", line 1291, in delete_security_group
    return self.get_status('DeleteSecurityGroup', params)
  File "/usr/lib/python2.6/site-packages/boto/connection.py", line 648, in get_status
    raise self.ResponseError(response.status, response.reason, body)
EC2ResponseError: EC2ResponseError: 400 Bad Request
<?xml version="1.0" encoding="UTF-8"?>
<Response><Errors><Error><Code>InvalidGroup.InUse</Code><Message>There are active instances using security group 'imagefactory-a13aee23-96cc-48ed-ba27-9aefee8e92e6'</Message></Error></Errors><RequestID>d9ac4dc0-7da5-403e-9eb4-62dff9f3cb72</RequestID></Response>
2011-09-07 11:38:30,278 DEBUG imagefactory.BuildJob.BuildAdaptor pid(2531) Message: Raising event with agent handler (<ImageFactoryAgent(Thread-1, initial)>), changed status from PUSHING to FAILED


Expected results:


Additional info:

Comment 1 Douglas Woods 2011-09-07 20:03:55 UTC
Created attachment 521995 [details]
Build image script for template.tpl

Comment 2 Douglas Woods 2011-09-07 20:04:27 UTC
Created attachment 521996 [details]
push image script to EC2 east

Comment 3 wes hayutin 2011-09-07 20:24:11 UTC
Douglas, can you please post the version of imagefactory you are using..

rpm -qa | grep factory

Comment 4 wes hayutin 2011-09-07 20:27:30 UTC
my current suggestion is to use f15 and http://repos.fedorapeople.org/repos/aeolus/conductor/testing/fedora-aeolus-testing.repo

Comment 5 Douglas Woods 2011-09-07 20:52:02 UTC
rubygem-imagefactory-console-0.4.0-1.el6.noarch
imagefactory-0.4.1-1.el6.noarch

Comment 6 Douglas Woods 2011-09-07 21:08:45 UTC
Tried push using the suggested repo above(http://repos.fedorapeople.org/repos/aeolus/conductor/testing/fedora-aeolus-testing.repo) and same results.

Comment 7 Jason Guiditta 2011-09-19 20:15:51 UTC
As this has to do with security groups, I am pretty sure this is something happening in either factory or oz, as aeolus-image is just a thin wrapper, reassigning for review by the factory guys.

Comment 8 wes hayutin 2011-09-28 16:39:29 UTC
making sure all the bugs are at the right version for future queries

Comment 10 Ian McLeod 2011-10-07 16:01:35 UTC
Looking closely at the error message above this really does seem to be a duplicate of something we have already fixed.  Updating status.

*** This bug has been marked as a duplicate of bug 726203 ***


Note You need to log in before you can comment on or make changes to this bug.