Bug 736526 - Virtio Win - not possible to "Change an existing device to use the para-virtualized drivers"
Summary: Virtio Win - not possible to "Change an existing device to use the para-virtu...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Deadline: 2012-01-27
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Virtualization_Host_Configuration_and_Guest_Installation_Gui
Version: 6.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Laura Bailey
QA Contact: ecs-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-07 22:56 UTC by John Brier
Modified: 2015-09-28 02:28 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-07 04:29:55 UTC


Attachments (Terms of Use)

Comment 6 Laura Novich 2012-01-24 08:41:43 UTC
I would ask Vadim Rozenfeld for more info

Comment 7 Laura Novich 2012-01-24 08:44:40 UTC
Also the bug doesn't contain enough information to see exactly where the problem is w/in the existing documentation.

I am wondering if the title should be changed, to reflect that it is a Windows installation?  I changed it, but if I am incorrect, pls change it back....

Comment 8 Vadim Rozenfeld 2012-01-24 20:56:09 UTC
Sure, it is not possible to update IDE device with viostor driver. They are just incompatible, and Windows installer will refuse to do it, no matter how hard we try. If we are taking this scenario, then you are absolutely right - the docs are really misleading. 
But I believe, they are talking about different situation: 
- a system (VM) has no viostor driver pre-installed; 
- a new virtio-blk device has been recently added to the system;
- on startup Windows recognized a new storage device plugged in;
- Windows PnP manager failed to find a device driver, which matches the new HW
  and installed a stub "SCSI controller" driver and put it under "Other devices"
  category;
In this case we do "update" driver. But we update a stub with a real driver.
Actually the same situation happens with the rest of out drivers - net, balloon and serial. Windows recognizes PCI class IDs and puts devices under predefined category, according to these ids.

So, we are not updating in-box drivers, which are running on top of emulated devices with our para-virtualized drivers. We update default (stub) drivers,
installed by Windows, with our functional device drivers.

Best,
Vadim.


Note You need to log in before you can comment on or make changes to this bug.