Bug 736527 - anaconda fails to parse its own auto-generated kickstart file's partitioning ('tried to use undefined partition')
Summary: anaconda fails to parse its own auto-generated kickstart file's partitioning ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedNTH RejectedBlocker
Depends On:
Blocks: F16Beta-accepted, F16BetaFreezeExcept
TreeView+ depends on / blocked
 
Reported: 2011-09-07 23:04 UTC by Adam Williamson
Modified: 2011-09-19 23:51 UTC (History)
2 users (show)

Fixed In Version: anaconda-16.18-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-19 23:51:37 UTC


Attachments (Terms of Use)

Description Adam Williamson 2011-09-07 23:04:51 UTC
I did a straight-through, all-defaults install of F16 Beta TC1, then took the generated /root/anaconda-ks.cfg , uncommented the partitioning lines, and uploaded it as:

http://www.happyassassin.net/extras/test.ks

then I tried an install from it, and got:

"The following error was found while parsing the kickstart configuration file:

The follow problem occurred on line 22 of the kickstart file:

Tried to use undefined partition pv.252003 in Volume Group specification"

Comment 1 David Lehman 2011-09-07 23:21:31 UTC
Looks like we need to sort these lines using either device dependencies, or maybe the action sorting, depending on whether it is action-based or device-based.

Comment 2 Adam Williamson 2011-09-08 01:07:56 UTC
Don't think dlehman's comment was meant to be private.

Proposing as a beta blocker, though this is a slight borderline case, under the new criterion:

"The installer must be able to successfully complete a scripted installation, using the installer's preferred scripting system, which duplicates the default interactive installation as closely as possible"

borderline in that arguably 'as closely as possible' means 'using the generated anaconda-ks.cfg' without changes, but really, editing it and uncommenting the partition lines makes the kickstart *closer* to the default installation, in a way. We can debate it at the meeting, anyway.

Comment 3 David Lehman 2011-09-08 18:44:02 UTC
Adam, you can try this:

  http://dlehman.fedorapeople.org/updates-736527.img

It worked for me with a single-disk qemu install. What it does it make sure anaconda writes out the partitioning lines in anaconda-ks.cfg in a reasonable order.

Comment 4 Adam Williamson 2011-09-09 17:42:16 UTC
Discussed at the 2011-09-09 blocker review meeting. We agreed this doesn't quite meet the definition of "duplicates the default interactive installation as closely as possible" because it's really to do with the auto-generation of kickstarts by anaconda; if you were to create a kickstart to duplicate a default install *from scratch* you wouldn't run into this. So we're taking it as NTH not blocker.

Comment 5 Adam Williamson 2011-09-13 00:24:06 UTC
updates.img definitely produces better ordering, it gives:

part.pv
volgroup
logvols
part /boot
part biosboot

only thing that worries me there is the /boot and biosboot partitions being after the LV - you'd think it'd be the other way around - but I'll test to see if that actually causes a problem.

Comment 6 Adam Williamson 2011-09-13 00:35:48 UTC
well, the system installs and boots fine, so apparently it ain't a problem. confirming the fix, please commit!

Comment 7 Fedora Update System 2011-09-15 00:43:54 UTC
anaconda-16.18-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.18-1.fc16

Comment 8 Fedora Update System 2011-09-15 15:15:55 UTC
Package anaconda-16.18-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-16.18-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-16.18-1.fc16
then log in and leave karma (feedback).

Comment 9 Adam Williamson 2011-09-16 00:19:27 UTC
Confirming this fix made it into RC1 and looks to be working well.

Comment 10 Fedora Update System 2011-09-19 23:51:11 UTC
anaconda-16.18-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.