Bug 73658 - Using locale instead of translating currency info in redhat-config-network
Using locale instead of translating currency info in redhat-config-network
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-07 18:40 EDT by Christian Rose
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-16 06:49:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2002-09-07 18:40:34 EDT
#: src/netconfpkg/gui/neat-control-propertiesdialog.glade.h:1
msgid "$"

I reckon that this is a dollar sign as in the currency USD.

It would probably be much better if redhat-config-network could use the locale's
currency information than having it "translated". For example, some languages
are used in more than one country and are hence used with many different
currencies, so hardcoding a default like this in the translation is probably
very wrong.

With this code snippet I get the currency from the locale's information on the
console:

#--------------------
#define _GNU_SOURCE
#include <langinfo.h>
#include <locale.h>
#include <stdio.h>

int main ()
{
  setlocale (LC_ALL, "");
  printf (nl_langinfo (__CURRENCY_SYMBOL));
  printf ("\n");
  return 0;
}
#--------------------

You could probably use something similar.
Comment 1 Harald Hoyer 2002-12-16 06:49:27 EST
unused
Comment 2 Christian Rose 2002-12-16 17:59:29 EST
If it's not used anymore, how come this is marked as notabug? If it's not a bug
anymore, a more suiting resolution probably is "resolved".

Note You need to log in before you can comment on or make changes to this bug.