Bug 73660 - Ping produces "WARNING: kernel is not very fresh, upgrade is recommended." messages
Ping produces "WARNING: kernel is not very fresh, upgrade is recommended." me...
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: iputils (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-07 20:51 EDT by Juha Saarinen
Modified: 2015-03-04 20:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-02 05:47:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juha Saarinen 2002-09-07 20:51:54 EDT
Description of Problem:
If you ping a host and get a destination net unreachable ICMP reply, ping 
prints the warning message in the summary field. Is this a valid message 
caused by a kernel bug as the source for ping implies, or just a spurious 
warning that should be removed? PLD has removed it from their version of ping.

Version-Release number of selected component (if applicable):

rpm -q --whatprovides $(which ping)
iputils-20020124-3

Name        : iputils                      Relocations: /usr
Version     : 20020124                          Vendor: Red Hat, Inc.
Release     : 3                             Build Date: Fri 19 Apr 2002
09:40:05 AM NZST
Install date: Fri 24 May 2002 02:33:11 PM NZST      Build Host:
stripples.devel.redhat.com
Group       : System Environment/Daemons    Source RPM:
iputils-20020124-3.src.rpm
Size        : 188776                           License: BSD
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : Network monitoring tools including ping.



How Reproducible:

Very.


Steps to Reproduce:
1. 

pts/2 juha@vim2:~$ ping w.netfirms.com
PING w.netfirms.com (209.171.43.26) from 192.168.1.15 : 56(84) bytes of data.
WARNING: kernel is not very fresh, upgrade is recommended.
From w.netfirms.com (209.171.43.26): icmp_seq=2 Destination Net Unreachable
From w.netfirms.com (209.171.43.26): icmp_seq=3 Destination Net Unreachable
From w.netfirms.com (209.171.43.26): icmp_seq=4 Destination Net Unreachable
From w.netfirms.com (209.171.43.26): icmp_seq=5 Destination Net Unreachable
From w.netfirms.com (209.171.43.26): icmp_seq=6 Destination Net Unreachable


2. 
3. 

Actual Results:


Expected Results:


Additional Information:
tcpdump -v icmp shows:

12:07:01.859472 vim2.saarinen.org > w.netfirms.com: icmp: echo request
(DF) (ttl 64, id 0, len 84)
12:07:02.089333 w.netfirms.com > vim2.saarinen.org: icmp: net
w.netfirms.com unreachable (ttl 47, id 0, len 56)
12:07:02.866957 vim2.saarinen.org > w.netfirms.com: icmp: echo request
(DF) (ttl 64, id 0, len 84)
12:07:03.096793 w.netfirms.com > vim2.saarinen.org: icmp: net
w.netfirms.com unreachable (ttl 47, id 0, len 56)


error_pkt = (icp->type != ICMP_REDIRECT &&
             icp->type != ICMP_SOURCE_QUENCH);
if (error_pkt) {
        acknowledge(icp1->un.echo.sequence);
        if (working_recverr) {
                return 0;
        } else {
                static int once;
                /* Sigh, IP_RECVERR for raw socket
                 * was broken until 2.4.9. So, we ignore
                 * the first error and warn on the second.
                 */
                 if (once++ == 1)
                      fprintf(stderr, "\rWARNING: kernel is not very fresh, 
upgrade is recommended.\n");
                 if (once == 1)
                       return 0;
        }
}
Comment 1 Phil Knirsch 2002-09-25 11:24:06 EDT
Nothing really serious.

Just follow the advice or ignore the message. :-)

Read ya, Phil
Comment 2 Juha Saarinen 2002-09-25 18:26:11 EDT
Well, you can't upgrade the kernel because there ain't no new kernel available 
for 7.3. 

This is what Debian stable does (formatting mangling courtesy of Bugzilla):

--- iputils-20020124.orig/ping.c
+++ iputils-20020124/ping.c
@@ -727,7 +727,7 @@
                                                 * the first error and warn on 
the second.
                                                 */
                                                if (once++ == 1)
-                                                       fprintf
(stderr, "\rWARNING: kernel is not very fresh, upgrade is recommended.\n");
+                                                        fprintf
(stderr, "\rWARNING: kernel is not very fresh, upgrade is recommended.\n");
                                                if (once == 1)
                                                        return 0;
                                        }
Comment 3 Juha Saarinen 2002-09-25 18:30:48 EDT
... and having actually looked at Debian's patch, I am at a loss to explain  
how it would fix the error message ;-). 

-- 
Juha
Comment 4 Phil Knirsch 2003-05-15 11:08:13 EDT
Have you tried kernel-2.4.18-27.7.x lately? I don't see the warning anymore on
our latest releases (RH 8 and RH 9)...

Thanks,

Read ya, Phil
Comment 5 Juha Saarinen 2003-05-15 17:39:53 EDT
Yep...

$ ping w.netfirms.com
PING w.netfirms.com (209.171.43.28) from 192.168.1.15 : 56(84) bytes of data.
WARNING: kernel is not very fresh, upgrade is recommended.

--- w.netfirms.com ping statistics ---
5 packets transmitted, 0 received, +3 errors, 100% loss, time 4050ms

pts/0 juha@vim2:~$ uname -a
Linux vim2 2.4.18-27.7.xcustom #2 Mon May 5 21:08:13 NZST 2003 i686 unknown

$ cat /etc/redhat-release
Red Hat Linux release 7.3 (Valhalla)

(Still waiting for your press handlers to flick something newer in my general 
direction :-)).

Comment 6 Phil Knirsch 2003-09-03 10:06:26 EDT
Have you given kernel-2.4.20-18.7 a try yet?

/me really wonders...

Read ya, Phil
Comment 7 Phil Knirsch 2003-10-02 05:47:38 EDT
OK, as i haven't been able to reproduce it here anymore with the latest kernels
and glibc i'm closing this bug as worksforme.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.