Bug 736603 - [libvirt][domblkinfo] libvirtd crash on domblkinfo.
Summary: [libvirt][domblkinfo] libvirtd crash on domblkinfo.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.1
Hardware: Unspecified
OS: Linux
unspecified
urgent
Target Milestone: beta
: ---
Assignee: Michal Privoznik
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 638510
Blocks: 743047
TreeView+ depends on / blocked
 
Reported: 2011-09-08 08:22 UTC by David Naori
Modified: 2011-12-06 11:28 UTC (History)
14 users (show)

Fixed In Version: libvirt-0.9.4-11.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 11:28:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1513 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2011-12-06 01:23:30 UTC

Description David Naori 2011-09-08 08:22:15 UTC
Description of problem:
libvirtd crash on domblkinfo. 

# pgrep libvirtd 19191
# virsh -r domblkinfo 1 vda
error: End of file while reading data: Input/output error
# pgrep libvirtd 20472

No core-dump, nothing in logs.

Version-Release number of selected component (if applicable):
libvirt-0.9.4-10.el6.x86_64


How reproducible:
100%

Comment 2 David Naori 2011-09-08 08:24:21 UTC
Worked on libvirt-0.9.4-7.el6.x86_64

Comment 3 Eric Blake 2011-09-08 08:32:35 UTC
I suspect my snapshot patches may be involved; in particular, my guess is this upstream commit:

commit 89b6284fd94ce5b13ee6b002f9167f5d9074aa7a
Author: Eric Blake <eblake@redhat.com>
Date:   Fri Aug 19 20:38:36 2011 -0600

    snapshot: also support disks by path
    
    I got confused when 'virsh domblkinfo dom disk' required the
    path to a disk (which can be ambiguous, since a single file
    can back multiple disks), rather than the unambiguous target
    device name that I was using in disk snapshots.  So, in true
    developer fashion, I went for the best of both worlds - all
    interfaces that operate on a disk (aka block) now accept
    either the target name or the unambiguous path to the backing
    file used by the disk.

Comment 4 Daniel Veillard 2011-09-08 08:37:18 UTC
yup seems to be an uninitialized disk variable should be easy to get fixed

Daniel

Comment 5 Eric Blake 2011-09-08 09:13:38 UTC
Upstream patch proposed:
https://www.redhat.com/archives/libvir-list/2011-September/msg00379.html

Comment 10 yuping zhang 2011-09-09 02:55:20 UTC
Reproduce this issue with libvirt-0.9.4-10.el6.x86_64.
Verified this issue with:
libvirt-0.9.4-11.el6.x86_64
kernel-2.6.32-193.el6.x86_64
qemu-kvm-0.12.1.2-2.185.el6.x86_64

# pgrep libvirtd
27271
# virsh -r domblkinfo 15 vda
Capacity:       8589934592
Allocation:     8589938688
Physical:       8589938688
# pgrep libvirtd
27271

So change the status to VERIFIED.

Comment 11 errata-xmlrpc 2011-12-06 11:28:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1513.html


Note You need to log in before you can comment on or make changes to this bug.