Bug 736618 - main components of Red Hat Network section is outdated
main components of Red Hat Network section is outdated
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Docs Reference Guide (Show other bugs)
520
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Lana Brindley
ecs-bugs
:
Depends On:
Blocks: sat54-docs
  Show dependency treegraph
 
Reported: 2011-09-08 05:24 EDT by mertensb
Modified: 2013-10-23 19:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-23 13:42:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description mertensb 2011-09-08 05:24:29 EDT
Description of problem:
The introductory description of the "main components of Red Hat Network" in chapter 1 Red Hat Network Overview describes "The Red Hat Update Agent (up2date)".  It says "Red
Hat Enterprise Linux 3 and newer systems use the Red Hat Update Agent to register with RHN.".  While RHEL5 and newer use yum rather than up2date.

Also the section "1.7. Before You Begin" only lists rhn_register and up2date but does not mention yum and other packages required for RHEL5 and up.


Additionally the section "4.5. Registering with Activation Keys" contains more outdated or release specific information.

It says:
To use an activation key, run the following command as root from a shell prompt on the system to be
registered:
rhnreg_ks --activationkey=7202f3b7d218cf59b764f9f6e9fa281b
The precise value of the activation key varies.
rhnreg_ks --serialnumber=7202f3b7d218cf59b764f9f6e9fa281b

There is no explanation about the second command using the --serialnumber option.  And on RHEL5.6 (rhn-setup-0.4.20-46.el5) there is no such option.

up2date-4.9.1-29.el4 on RHEL 4.9 and even up2date-4.5.5-8.el3 on RHEL3.9 report that the option --serialnumber is deprecated.
Comment 1 Clifford Perry 2011-09-23 13:42:19 EDT
Hi there, this is a lower priority bug report, suitable for a major release of Satellite. Currently there is no plans to release a 5.5 Satellite. The next set of major documentation released for Systems Management will involve our CloudForms product documentation. As such, we will write from scratch similar introduction chapters. 

I'm going to proceed to close this bug out as Deferred and something we plan not to address. We can re-open if plans change. 

Cliff

Note You need to log in before you can comment on or make changes to this bug.