Bug 736679 - v7 storage test: improper dt options for raw I/O test
Summary: v7 storage test: improper dt options for raw I/O test
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Caspar Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-08 12:20 UTC by WANG Chao
Modified: 2015-02-08 21:42 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In v7 1.3, storage test enabled aio option in both buffered I/O testing and raw I/O testing, which was incorrect since raw I/O should be unbuffered. This issue has been fixed in v7 1.4, now v7 storage test uses "flags=direct" option in raw I/O testing instead of using aio.
Clone Of:
Environment:
Last Closed: 2011-11-08 15:43:05 UTC


Attachments (Terms of Use)
patch fix (4.31 KB, patch)
2011-09-08 12:26 UTC, WANG Chao
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1436 normal SHIPPED_LIVE v7 bug fix and enhancement update 2011-11-08 23:28:41 UTC

Description WANG Chao 2011-09-08 12:20:09 UTC
Description of problem:
After code review of /usr/share/v7/tests/storage/storage.py, I found that
dt has a global option 'enable=aio' and I think that is improper for raw I/O test.
raw I/O test should be non-buffered, need to directly write to the block layer.And aio option use memory cache, and may confuse test result.I think remove this option and just with 'flags=direct' is more proper

Version-Release number of selected component (if applicable):
14

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 WANG Chao 2011-09-08 12:26:42 UTC
Created attachment 522103 [details]
patch fix

This patch also fix:
bug 736638 , bug 736666 and bug 736675

Comment 4 Caspar Zhang 2011-10-21 15:25:29 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
In v7 1.3, storage test enabled aio option in both buffered I/O testing and raw I/O testing, which was incorrect since raw I/O should be unbuffered. This issue has been fixed in v7 1.4, now v7 storage test uses "flags=direct" option in raw I/O testing instead of using aio.

Comment 5 Caspar Zhang 2011-11-02 10:31:10 UTC
Recent tests passed. Move to "VERIFIED"

Comment 6 errata-xmlrpc 2011-11-08 15:43:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1436.html

Comment 7 errata-xmlrpc 2011-11-08 18:33:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1436.html


Note You need to log in before you can comment on or make changes to this bug.