Bug 736721 - installation can't continue, keeps asking to insert the Fedora disc
installation can't continue, keeps asking to insert the Fedora disc
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
powerpc Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Alphappc
  Show dependency treegraph
 
Reported: 2011-09-08 10:05 EDT by Karsten Hopp
Modified: 2012-03-14 09:06 EDT (History)
4 users (show)

See Also:
Fixed In Version: anaconda-16.18-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-19 19:51:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My stab at it (3.90 KB, patch)
2011-09-12 11:11 EDT, Mark Hamzy
no flags Details | Diff

  None (edit)
Description Karsten Hopp 2011-09-08 10:05:30 EDT
Description of problem:
After the partitions got formatted the DVD gets ejected and a window pops up: 'Please insert the Fedora disc to continue'

Version-Release number of selected component (if applicable):
anaconda-16.16-1.fc16

How reproducible:
always

Steps to Reproduce:
1. install from DVD, p.e.  http://ppc.koji.fedoraproject.org/scratch/karsten/iso/Fedora-20110907-ppc64-DVD-respin.iso
2. proceed until after the partitioning gets written to the disk
3. 
  

Additional info:
# cat .discinfo
1315411999.092447
Fedora 20110907
ppc64
Comment 1 Will Woods 2011-09-09 10:10:19 EDT
Is it the 'ppc64' causing the problem? Anaconda's probably expecting 'ppc'. I'll check into it.
Comment 2 Mark Hamzy 2011-09-12 11:11:52 EDT
Created attachment 522721 [details]
My stab at it

I took the isX86 approach for isPPC
Comment 3 Will Woods 2011-09-12 17:36:59 EDT
I'm not really happy with this, because it breaks the ability to have a ppc runtime with a ppc64 kernel.

For the moment the simplest workaround is probably to force lorax to write 'ppc' into the .discinfo file for all ppc arches.

I'm starting to think changing the basearch for ppc64 to 'ppc64' was the wrong idea. It's causing a lot of problems and I'm not sure what it fixes (e.g. I'm pretty sure we could build pure-ppc64 trees before that change was made).
Comment 4 Will Woods 2011-09-14 11:31:54 EDT
After some consideration of the problem I've applied a version of the patch from comment #2 (thanks, Mark!). It's only sensible: if yum considers the basearch for ppc64 to be 'ppc64', so should anaconda.

We'll need some other way to hack in the old support for 32-bit images with a 64-bit kernel, but that'll come later. First, let's make it work.

Patches applied in git master:

  facb60a iutil: make getArch() return ppc64 on ppc64 (#736721)
  9249b08 iutil: add 'bits' arg to isPPC (like isX86)

and f16-branch:

  d751bce iutil: make getArch() return ppc64 on ppc64 (#736721)
  9fd72aa iutil: add 'bits' arg to isPPC (like isX86)
Comment 5 Fedora Update System 2011-09-14 20:44:12 EDT
anaconda-16.18-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/anaconda-16.18-1.fc16
Comment 6 Fedora Update System 2011-09-15 11:16:13 EDT
Package anaconda-16.18-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-16.18-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-16.18-1.fc16
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2011-09-19 19:51:31 EDT
anaconda-16.18-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.