Bug 736739 - usbutils update moves lsusb from /usr/sbin to /usr/bin
Summary: usbutils update moves lsusb from /usr/sbin to /usr/bin
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: usbutils
Version: 6.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 6.2
Assignee: Jiri Moskovcak
QA Contact: Iveta Wiedermann
URL:
Whiteboard:
Depends On:
Blocks: 691477 743047 807263
TreeView+ depends on / blocked
 
Reported: 2011-09-08 15:01 UTC by Bryn M. Reeves
Modified: 2015-02-01 22:54 UTC (History)
6 users (show)

Fixed In Version: usbutils-003-3.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 807263 (view as bug list)
Environment:
Last Closed: 2011-12-06 16:18:39 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1646 normal SHIPPED_LIVE usbutils bug fix and enhancement update 2011-12-06 00:50:34 UTC

Description Bryn M. Reeves 2011-09-08 15:01:05 UTC
Description of problem:
usbutils-003-2.el6 moves the lsusb binary from /usr/sbin to /usr/bin:

# rpm -qlp usbutils-0.86-2.el6.x86_64.rpm | grep bin
/usr/bin/usb-devices
/usr/sbin/lsusb

# rpm -qlp usbutils-003-2.el6.x86_64.rpm | grep bin
/usr/bin/lsusb
/usr/bin/lsusb.py
/usr/bin/usb-devices
/usr/bin/usbhid-dump

This breaks distribution & third party scripts that rely on the old location.

Version-Release number of selected component (if applicable):
usbutils-003-2.el6

How reproducible:
100%

Steps to Reproduce:
1. $ /usr/sbin/lsusb

Actual results:
-bash: /usr/sbin/lsusb: No such file or directory

Expected results:
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
[...]

Additional info:
A symlink to the old location would retain compatibility with the path used in previous RHEL6 updates.

Comment 6 errata-xmlrpc 2011-12-06 16:18:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1646.html


Note You need to log in before you can comment on or make changes to this bug.