Bug 736763 - pvs is unable to display hundreds of PVs: 'dm_report: left-aligned snprintf() failed'
Summary: pvs is unable to display hundreds of PVs: 'dm_report: left-aligned snprintf()...
Keywords:
Status: CLOSED DUPLICATE of bug 734803
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2
Version: 6.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: LVM and device-mapper development team
QA Contact: Corey Marthaler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-08 16:03 UTC by Corey Marthaler
Modified: 2011-09-08 16:12 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-08 16:12:12 UTC


Attachments (Terms of Use)

Description Corey Marthaler 2011-09-08 16:03:27 UTC
Description of problem:
This issue kind of blocks the ability to test 6.2 bugs 697945 and 698393.

[root@taft-03 ~]# pvs
  PV          VG        Fmt  Attr                             PSize  PFree
  /dev/sda2   vg_taft03 lvm2 a--                              67.75g    0 
  /dev/sdb1             lvm2 a--                               1.33g 1.33g
  /dev/sdb10            lvm2 a--                               1.33g 1.33g
  /dev/sdb100           lvm2 a--                               1.33g 1.33g
  /dev/sdb11            lvm2 a--                              1.33g 1.33g
  /dev/sdb12            lvm2 a--                              1.33g 1.33g
  /dev/sdb13            lvm2 a--zcMOV                          1.33g 1.33g
  /dev/sdb14            lvm2 a--                               1.33g 1.33g
  /dev/sdb15            lvm2 a--                               1.33g 1.33g

  [...] 

  /dev/sdc36            lvm2 a--                               1.33g 1.33g
  /dev/sdc37            lvm2 a--                               1.33g 1.33g
  dm_report: left-aligned snprintf() failed

Version-Release number of selected component (if applicable):
2.6.32-193.el6.x86_64

lvm2-2.02.87-1.el6    BUILT: Fri Aug 12 06:11:57 CDT 2011
lvm2-libs-2.02.87-1.el6    BUILT: Fri Aug 12 06:11:57 CDT 2011
lvm2-cluster-2.02.87-1.el6    BUILT: Fri Aug 12 06:11:57 CDT 2011
udev-147-2.37.el6    BUILT: Wed Aug 10 07:48:15 CDT 2011
device-mapper-1.02.66-1.el6    BUILT: Fri Aug 12 06:11:57 CDT 2011
device-mapper-libs-1.02.66-1.el6    BUILT: Fri Aug 12 06:11:57 CDT 2011
device-mapper-event-1.02.66-1.el6    BUILT: Fri Aug 12 06:11:57 CDT 2011
device-mapper-event-libs-1.02.66-1.el6    BUILT: Fri Aug 12 06:11:57 CDT 2011
cmirror-2.02.87-1.el6    BUILT: Fri Aug 12 06:11:57 CDT 2011


How reproducible:
Everytime

Comment 1 Corey Marthaler 2011-09-08 16:10:21 UTC
This is most likely bug 734803.

Comment 2 Alasdair Kergon 2011-09-08 16:12:12 UTC

*** This bug has been marked as a duplicate of bug 734803 ***


Note You need to log in before you can comment on or make changes to this bug.