Bug 736790 - Fedora 16 gives black screen on HP dv6-6145eo (regression)
Fedora 16 gives black screen on HP dv6-6145eo (regression)
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2011-09-08 13:37 EDT by Markus Ilmola
Modified: 2013-02-26 10:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-02-26 10:14:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Output of lscpi -v. Generated with Fedora 15. (11.67 KB, text/plain)
2011-09-08 13:37 EDT, Markus Ilmola
no flags Details
dmesg from FC-16 boot on HP dv6 (93.92 KB, text/plain)
2011-12-09 01:22 EST, Dave Miller
no flags Details

  None (edit)
Description Markus Ilmola 2011-09-08 13:37:59 EDT
Created attachment 522172 [details]
Output of lscpi -v. Generated with Fedora 15.

Description of problem:
When trying to boot Fedora 16 graphics test iso on HP dv6-6145eo only black screen appears. CPU: 3410MX APU. GPU: Radeon HD 6755G2 (6520G and 6750M CrossFire)

How reproducible:
Happens every time.

Steps to Reproduce:
1. Download the Fedora 16 graphics test iso: http://adamwill.fedorapeople.org/graphics_test_week_20110905/graphics_test_week-20110905-x64.iso
2. Burn to CD
3. Boot from the CD
Actual results:
After the boot countdown only black screen appears (not even the screen back light is on)

Expected results:
Computer should boot to the desktop.

Additional info:
This bug is only in Fedora 16. Fedora 15 works, so this is a regression.
Smolt profile (generated with Fedora 15, not with Fedora 16) http://www.smolts.org/client/show/pub_789ecf60-f962-4533-8dce-0b3551ba725c
This bug might be related to bug #733857
Comment 1 Matěj Cepl 2011-09-09 18:10:03 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information especially concerning your hardware we require that will be helpful in our diagnosis of this issue.

If the anaconda crashes during the switching to the graphic mode, most likely the problem lies in Xorg support for your graphics chip. There are couple of options how we can obtain information necessary for resolving the issue.

If the computer is not completely frozen when installation fails, switch to the console (Ctrl+Alt+F2) and copy /tmp/X* and /var/log/anaconda.xlog to some other place -- USB stick, some other computer via network, somewhere on the Internet, and please attach it to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

If the computer is completely useless after installation fails, you can also install Fedora with a VESA mode driver (see http://docs.fedoraproject.org/en-US/Fedora/13/html/Installation_Guide/
for more information on that). Then after successful installation you can collect /var/log/anaconda.xlog, /var/log/Xorg.0.log, and the output of the program dmesg instead.

Or you can install Fedora in a text mode completely, and then start X after that. If it fails, still /var/log/Xorg.0.log and the output of dmesg program from the failed attempt to start X would be useful.

We will review this issue again once you've had a chance to attach this information.

Thank you very much in advance.
Comment 2 Dave Miller 2011-12-08 22:22:15 EST
Not the original filer but I just recreated this on a HP dv6.  I currently have FC-16 installed on an external hard disk so I have a little flexibility.  When booting with different hardware, I set up Fedora to come up in the equivalent of run level 3.  I then shutdown that system (an older HP laptop) and rebooted the dv6 with the new configuration.  Again, I got only a black screen.  I was able to login and do things like reboot or shutdown the system from the invisible command line (type very carefully).

Interestingly, I turned off rhgb and quiet mode in grub and the normal boot spewage appears as expected.  The display seems to pack up about when the graphical progress indicator would appear.  Since the problem occurs when booting in text mode, I doubt that the X.org log would be of any help.  This setup (same external hard drive and laptop) work as expected with Backtrack 5R2 and CentOS 6.

Let me know if there is anything else I can do or additional information I can extract for you.
Comment 3 Dave Miller 2011-12-09 01:22:27 EST
Created attachment 544352 [details]
dmesg from FC-16 boot on HP dv6

Do a search for "Synaptics" since the touch pad initializes right before the video.  I found the following odd since it appears that the monitors are detected and then "No monitor connected or invalid EDID".

[    2.415580] [drm] Radeon Display Connectors
[    2.415795] [drm] Connector 0:
[    2.415959] [drm]   VGA
[    2.416135] [drm]   HPD2
[    2.416290] [drm]   DDC: 0x6440 0x6440 0x6444 0x6444 0x6448 0x6448 0x644c 0x644c
[    2.416533] [drm]   Encoders:
[    2.416696] [drm]     CRT1: INTERNAL_UNIPHY2
[    2.416861] [drm]     CRT1: NUTMEG
[    2.417035] [drm] Connector 1:
[    2.417169] [drm]   LVDS
[    2.417318] [drm]   HPD1
[    2.417470] [drm]   DDC: 0x6430 0x6430 0x6434 0x6434 0x6438 0x6438 0x643c 0x643c
[    2.417690] [drm]   Encoders:
[    2.417841] [drm]     LCD1: INTERNAL_UNIPHY2
[    2.417993] [drm]     LCD1: TRAVIS
[    2.418156] [drm] Connector 2:
[    2.418306] [drm]   HDMI-A
[    2.418456] [drm]   HPD4
[    2.418607] [drm]   DDC: 0x6460 0x6460 0x6464 0x6464 0x6468 0x6468 0x646c 0x646c
[    2.418828] [drm]   Encoders:
[    2.418978] [drm]     DFP1: INTERNAL_UNIPHY
[    2.533229] usb 4-2: New USB device found, idVendor=138a, idProduct=0018
[    2.533488] usb 4-2: New USB device strings: Mfr=0, Product=0, SerialNumber=1
[    2.533737] usb 4-2: SerialNumber: f89261418a9d
[    2.539077] [drm] Radeon display connector VGA-1: No monitor connected or invalid EDID
[    2.659033] [drm] Radeon display connector LVDS-1: No monitor connected or invalid EDID
[    2.762192] usb 3-5: new full speed USB device number 2 using ohci_hcd
[    2.779066] [drm] Radeon display connector HDMI-A-1: No monitor connected or invalid EDID

Also, the behavior is the same regardless of whether the second monitor is attached or not, powered on or not...  I was hoping I could at least get the external monitor to work so I tried everything I could think of.
Comment 4 Dave Miller 2011-12-10 01:32:05 EST
Just so there's also a workaround here (it's also probably a hint as to the problem)... you can use the kernel parameter nomodeset to stop the startup process from going to graphical mode.  This actually seems to be the problem (although I'd rather blame Plymouth).  I finally got Plymouth to go to the "Details" theme and the screen still went dead when the display went from 80x25 text to some graphical mode during boot.

Funny thing is that I had almost exactly the same problem when I first installed Linux on my old laptop (the one that has been working with FC-16).  In that case the external monitor worked even though graphical mode boot didn't for the laptop's flat-panel.
Comment 5 Fedora End Of Life 2013-01-16 15:59:16 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 6 Fedora End Of Life 2013-02-26 10:14:35 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.