Bug 736793 - gdm 3.1.90-1 No way to reboot or shutdown system from gdm
Summary: gdm 3.1.90-1 No way to reboot or shutdown system from gdm
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-08 17:40 UTC by Daniel Belton
Modified: 2011-11-16 11:08 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-16 10:57:30 UTC


Attachments (Terms of Use)
yum update log (14.23 KB, text/plain)
2011-09-22 17:20 UTC, Kamil Páral
no flags Details

Description Daniel Belton 2011-09-08 17:40:59 UTC
Description of problem: Ther eis no way to shutdown or reboot the system from gdm


Version-Release number of selected component (if applicable): 3.1.90-1


How reproducible: Always. Start system, gdm comes up. There is no way to shutdown or reboot from the gdm login screen.


Steps to Reproduce:
1. start system
2. gdm starts
3. no shutdown or reboot
  
Actual results:

There is no shutdown or reboot from the gdm login screen

Expected results:

For there to be a way to shutdown or reboot from the gdm login screen


Additional info:

With the crazy mixed up idea that a user must log out to be able to shutdown their system that was introduced in Gnome 3, The ability to shutdown or reboot from the gdm screen is a MUST. 

With no shutdown in the Gnome 3 shell menu, and no shutdown in gdm, Ther eis now no noticable way to shutdown the system.

Comment 1 Matthias Clasen 2011-09-09 13:47:54 UTC
Tracked upstream here: https://bugzilla.gnome.org/show_bug.cgi?id=657364

Comment 2 Daniel Belton 2011-09-09 16:44:29 UTC
Are you sure about that gnome bug report?

It appears that one is related to the gnome-settings-daemon crashing when selecting background, not shutdown/reboot being missing from gdm.

Comment 3 Kamil Páral 2011-09-22 08:10:47 UTC
Link in comment 1 really doesn't seem to be related. Reopening this. I can confirm that restart/poweroff options are missing in gdm 3.1.90 and 3.1.92 running in "gnome-shell mode" (3D accelerated). However, when I run it in KVM (fallback mode), gdm *contains* reboot/poweroff options.

Comment 4 Kamil Páral 2011-09-22 08:16:25 UTC
Proposing as a blocker, Gnome 3 in accelerated mode now offers no option to reboot, and we shouldn't push that to our users.

Comment 5 solanum 2011-09-22 13:10:04 UTC
This needs to be an -option-. 

For instance, at work, I don't want people to walk up to my workstation and randomly shut it down as it is a multi-user machine while no one is logged into the console, it doesn't mean the machine is being used remotely. And quite frankly any random person shouldn't be allowed access to shutoff the machine. 

At home, it is handy only because accelerated gnome isn't offering a shutdown option for a --logged-- user.

Comment 6 Matthias Clasen 2011-09-22 16:58:00 UTC
gdm 3.1.92 _does_ have restart/suspend/power off options, in both fallback and regular mode.

Comment 7 Kamil Páral 2011-09-22 17:20:57 UTC
Created attachment 524455 [details]
yum update log

Soooo. When I installed gdm 3.1.92 manually, it doesn't have those options. 3.1.90 neither. But when I updated my system to latest updates-testing, that options appeared.

I don't know which package caused that, attaching the transaction log. I can try to downgrade some suspected packages to pinpoint the correct one, just tell me your suggestions.

Comment 8 Matthias Clasen 2011-09-22 17:50:46 UTC
I don't think there's any need for extended forensics here.
Just enjoy your new button :-)

Comment 9 Adam Williamson 2011-09-22 20:07:00 UTC
well, there is a need for extended forensics to some degree. we need to be sure that the combination of gdm 3.1.92 plus whatever else is in beta has working PM options in both Shell and fallback cases, and also live. As long as that's the case, then we're okay, but we should make sure that's the case.

I'll try and test this today.

Comment 10 Adam Williamson 2011-09-23 00:09:55 UTC
In a live image built with the current planned RC2 package set, including gdm 3.1.92 but no other 3.1.92 stuff, I see shutdown/restart options when booting in a VM - i.e., fallback style - and logging out from the live user's desktop, but not when doing the same thing on bare metal and getting the Shell.

Will check post-install situation soon.

Comment 11 Tim Flink 2011-09-23 18:32:03 UTC
Discussed in the 2011-09-23 blocker review meeting. Rejected as a Fedora 16 beta blocker because even though it does violate the beta release criteria [1], the only possible fix is to pull in gnome-shell-2.1.92 which is a little big to be re-testing this close to beta release.

Comment 12 Adam Williamson 2011-09-23 18:48:18 UTC
I would actually argue that it doesn't violate the criteria. The relevant criterion is:

"All release-blocking desktops' offered mechanisms (if any) for shutting down, logging out and rebooting must work "

In this case, no mechanisms are offered. We don't actually require mechanisms to be offered.

Comment 13 Kamil Páral 2011-09-23 19:56:36 UTC
(In reply to comment #11)
> Discussed in the 2011-09-23 blocker review meeting. Rejected as a Fedora 16
> beta blocker because even though it does violate the beta release criteria [1],
> the only possible fix is to pull in gnome-shell-2.1.92 which is a little big to
> be re-testing this close to beta release.

Your formulation sounds like "it is considered a blocker, but we can't solve it for beta". Does it make sense to propose it as a final blocker then?

(In reply to comment #12)
> I would actually argue that it doesn't violate the criteria. The relevant
> criterion is:
> 
> "All release-blocking desktops' offered mechanisms (if any) for shutting down,
> logging out and rebooting must work "
> 
> In this case, no mechanisms are offered. We don't actually require mechanisms
> to be offered.

It doesn't violate the criteria directly, yes, but that doesn't mean it can't be a blocker, right? The criteria can't describe all possibilities. In this case I believe it should be a blocker, because 1) the gnome developers says the reboot option should be present (i.e. it's not intentional) 2) no other user friendly way to reboot is available.

Hopefully this will get solved once all updates from updates-testing are pushed into stable.

Comment 14 Adam Williamson 2011-09-23 20:24:23 UTC
"Hopefully this will get solved once all updates from updates-testing are pushed
into stable."

Yes, it will.

"It doesn't violate the criteria directly, yes, but that doesn't mean it can't
be a blocker, right? The criteria can't describe all possibilities."

Yes, we can always propose new criteria if we think they're warranted. In this case we could propose a criterion like "the login manager must offer shutdown / reboot options" or whatever.

Comment 15 Adam Williamson 2011-09-23 22:34:29 UTC
take it off the blocker list, re-assign to gnome-shell, set ON_QA.

Comment 16 Daniel Belton 2011-10-06 13:25:22 UTC
It appears that this bug has been fixed for me. At least the options have returned on the GDM login screen have returned.

I am not going to update the status on this bug since there are several things going on here, so I will leave it up to someone else to decide if it should be closed or not.

Comment 17 Kamil Páral 2011-11-16 10:57:30 UTC
Fixed long time ago.


Note You need to log in before you can comment on or make changes to this bug.