Bug 736873 - Fails on platforms such as arm where char is an unsigned type
Summary: Fails on platforms such as arm where char is an unsigned type
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: speedcrunch   
(Show other bugs)
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Roland Wolters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-08 22:10 UTC by Henrik Nordström
Modified: 2011-10-08 21:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-08 21:29:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch fixing the most obvious char misuse (416 bytes, patch)
2011-09-08 22:10 UTC, Henrik Nordström
no flags Details | Diff

Description Henrik Nordström 2011-09-08 22:10:40 UTC
Created attachment 522213 [details]
Patch fixing the most obvious char misuse

Description of problem:

Fails to build on arm architecture due to unsigned char

Version-Release number of selected component (if applicable):

speedcrunch-0.11-0.2.alpha.fc15

How reproducible:

always

Steps to Reproduce:
1. Try to build on an platform where char is unsigned
2.
3.
  
Actual results:

One of the tests in the selftest gets stuck in an infinite loop

Expected results:

Successful build

Additional info:

Attached patch is sent upstream for merge.

Comment 1 Henrik Nordström 2011-09-30 08:07:39 UTC
Patch have been merged upstream. https://gitorious.org/speedcrunch/mainline/commit/91c1c0c4a205fa1ccf8679bda5941728c6d0cd15

Comment 2 Henrik Nordström 2011-10-01 21:26:13 UTC
Would be great if a new F15 (and later) build can be done with this patch, giving the arm architectrures a stable nvr to reference.

Comment 3 Daniel Drake 2011-10-08 21:29:52 UTC
fixed in speedcrunch-0.11-0.3.alpha


Note You need to log in before you can comment on or make changes to this bug.